[chirp_users] digital encoding

Robert Withers
Fri Apr 9 12:42:39 PDT 2021

Hi Chuck,

Your email is very encouraging. I failed my Tech exam yesterday, so I am studying more with some online practice exams on eham,com. I will retest in May. Meanwhile I have setup some of the local channels on my radio but have not heard any traffic. I think I set the PL codes correctly.

Regarding digital, I need to learn the apropos frequencies and the apropos packet specifications (WinLink?). I am reading from the ARRL Operating Manual, which talks about something like

- EchoLink
- Winlink
- Manchester
- Miller

My intuition is that these are ways to encode binary data on an audio transmission/reception signal, both digital and analog signals.

The encoding of data from software structures into bytes occurs just above these encodings. I have some specified encodings of common objects I use, using ASN.1 encoding, but more could be added such as weather SITREPs, stock info and transmission triangulation data, for instance. After encoding the high level objects into bytes, then the RFmessage/signal encoding would occur (from the list above). Currently my ParrotTalk protocol handshake objects are encoded as well as messages supporting distributed objects. I use TCP, not UDP, so the idea of a broadcast message is still a bit foreign to me.

Here is my Java code, I think it still works, but my core development occurs in Squeak and I am advancing the implementation, including per-connection config, which will need up-dating the Java implementation. https://github.com/CallistoHouseLtd/ParrotTalk

Is there another established mailing list for digital comms over RF or might we start one so we do not interfere in this list, as we are off-topic?

I appreciate you.


On 4/8/21 4:26 PM, Chuck Hast wrote:

> Robert,
> I for one am interested in what you are working on.
> That is where radio is headed like it or not. As long
> as we set and use 40 year old analog voice tech we
> are going nowhere. On top of that all of the tech
> vultures are circling ready to grab up our spectrum,
> it is use it or lose it. We lost 3.5Ghz to the cellular
> folks, they are trying to grab our piece of 5.8Ghz.
> If you are running a digital repeater you well maybe
> using one of those bands as part of your link to your
> digital repeater.
> Glad that you got the cable thing straight in order to
> use Chirp to do the radio programming and wish
> you luck with the digital work, we need to see more
> of it in this hobby (as buzzards circle). The zombie
> analog repeater count is extremely high everywhere
> I travel, I think you could give a safety of life alert
> on most of them and no one would hear you. At least
> on most of the digital systems I know that I can get
> on a talk group and get someone.
> Keep up the good work.
> On Wed, Apr 7, 2021 at 7:35 PM Robert Withers via chirp_users <chirp_users at intrepid.danplanet.com> wrote:
>> Hey! It worked! I had to seat the cable one last click, as I saw ttyUSB0 disappear and then appear on unplugging then plugging in the USB and I also had ftdi_sio module installed. I seated the cable firmly and read the radio config.
>> Thanks so much and I would say I apologize for all my encoding BS clogging the thread on the wrong list. Forgive me my excess. I do not mean to antagonize. Just searching for information to become a productive member of the radio community.
>> Kindly,
>> Robert
>> On 4/7/21 8:15 PM, W Paul Mills wrote:
>>> Certainly looks to me like you are trying to make this too hard. Modules needed are loaded usbserial and ftdi_sio.
>>> Simply do "ls -l /dev/ttyUSB*" before and after plugging in the cable. You should then know for sure which port to use. Otherwise most common cause of no response from radio is poor connection on the radio end. Try seating the cable with a little extra push. In some cases, cables have even needed to be trimmed a bit to properly seated.
>>> I can't believe all the BS in this tread.
>>> On 4/7/21 9:19 AM, Robert Withers via chirp_users wrote:
>>>> Hi Eric,
>>>> Thanks for pointing me this way, although it seems I am not auto configuring a module for ttyUSB0. I am attaching the output of
>>>>> lsmod | sed -n 'p;$=' > lsmod-count.txt
>>>> Where the last line is a line count. There is no changes in this output between having the phoe unplugged versus plugged, so perhaps that is an indicator that auto-config of a module to talk to the radio is misfiring. I dunno. Is this where modprobe comes in? What module name should I install for Chirp managing traffic over ttyUSB0?
>>>> Thanks!
>>>> Robert
>>>> On 4/6/21 9:04 PM, Eric Oyen via chirp_users wrote:
>>>>> Well,
>>>>> It does depend on the GUI. There is actually a control panel of sorts if you use Unity or gnome as your desktop. Under there will be a number of “applets” for hardware configuration. This was the gnome project idea of mimicking a windows interface as well as it’s control panel. However, it is sometimes not as useful as being able to troubleshoot and add/remove devices from the CLI. One should look up lsmod as well as modprobe and Insmod. If things are working correctly, new devices will always appear in the /dev directory and may even have some sort of “magic number” associated with them. That’s an advanced idea and shouldn’t really be of concern for this discussion.
>>>>> Now, if you use the “Lsmod” command (not capitalized, as my stupid autocorrect is trying to change it) before you plug in the usb cable, you should see a list of modules and what they do. After plugging in the cable that connects to your radio, and doing the same command, you should see 1 or more new modules loaded. Those modules will be associated with new devices that show up under /dev. Now, they may be listed as TTYS0 or TTYS1, etc. those would be your comm port entries. ttys0 should be associated with comm 1, etc.
>>>>> Now, if your system is properly configured, then most of this already happens in background. However, there may be some cases where you may have to add your user account to the appropriate group in order to use the device. There are GUI programs for this as well as some CLI commands. Now, some of the commands above may require that you use sudo and log into root. 2 items of caution here:
>>>>> 1. If you are unsure, don’t use sudo
>>>>> 2. Sudo is dangerous if you mess up. Only for advanced users! So, be very careful if you do have to use it.
>>>>> As always, read the associated man pages.
>>>>> DE n7zzt Eric
>>>>>> On Apr 6, 2021, at 4:24 PM, Al Jones <al at aljones.us> wrote:
>>>>>> It appears as if we have a computer newbie on our hands since he's looking fordevice manageron Ubuntu ... one of you good linux guys want to take him in hand and walk him through?
>>>>>> I'm no help, I know a bit about linux but like most of the world I live in windows.
>>>>>> //al
>>>>>> ------ Original Message ------
>>>>>> From: "Matthew Poletiek" <matthew.poletiek at gmail.com>
>>>>>> To: "Robert" <robert.withers at pm.me>; "Discussion of CHIRP" <chirp_users at intrepid.danplanet.com>
>>>>>> Sent: Tue 4 6 21 18:20:30
>>>>>> Subject: Re: [chirp_users] Download From Radio under Ubuntu 20.04 error
>>>>>>> Hi Robert,
>>>>>>> You might want to check to make sure your user has proper permissions.
>>>>>>> In linux, typically the groups you might need for this kind of
>>>>>>> operation include `dialout`, `usb`, and while you're at it you might
>>>>>>> as well include `plugdev`.
>>>>>>> The command to add your user to a group might be `sudo gpasswd -a <user> group`.
>>>>>>> Once thats finished you might need to refresh your profile. Either try
>>>>>>> opening CHIRP in a new terminal, or log out and log back in.
>>>>>>> -------------------------------------------
>>>>>>> Matthew Poletiek
>>>>>>> 303.810.9082
>>>>>>> matthew.poletiek at gmail.com
>>>>>>> [www.matthewpoletiek.com](http://www.matthewpoletiek.com/)
>>>>>>> On Tue, Apr 6, 2021 at 5:56 PM Robert via chirp_users
>>>>>>> <chirp_users at intrepid.danplanet.com> wrote:
>>>>>>>> Nigel,
>>>>>>>> Here is some more info, I think this is saying it is attached to /dev/ttyUSB0, but same issue.
>>>>>>>> rabbit at ganymede:/dev$ dmesg | grep tty
>>>>>>>> [ 0.108543] printk: console [tty0] enabled
>>>>>>>> [ 0.396294] 00:05: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A
>>>>>>>> [ 0.418318] 0000:00:16.3: ttyS4 at I/O 0xf0e0 (irq = 19, base_baud = 115200) is a 16550A
>>>>>>>> [ 9667.132474] usb 1-1.1.3: FTDI USB Serial Device converter now attached to ttyUSB0
>>>>>>>> [10669.642560] ftdi_sio ttyUSB0: FTDI USB Serial Device converter now disconnected from ttyUSB0
>>>>>>>> [10670.495576] usb 1-1.1.3: FTDI USB Serial Device converter now attached to ttyUSB0
>>>>>>>> Kindly,
>>>>>>>> Robert
>>>>>>>> . .. ... ‘...^,^
>>>>>>>> ‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
>>>>>>>> On Tuesday, April 6th, 2021 at 5:51 PM, Nigel A. Gunn G8IFF/W8IFF <nigel at ngunn.net> wrote:
>>>>>>>>> Usually /dev/ttyUSB0 unless you already have another serial device already plugged in to a USB port.
>>>>>>>>> Go to file manager and look in /dev/ and see what appears and disappears when you plun in and unplug the cable.
>>>>>>>>> > On 06/04/2021 17:34 Robert via chirp_userschirp_users at intrepid.danplanet.comwrote:
>>>>>>>>> >
>>>>>>>>> > Hello,
>>>>>>>>> >
>>>>>>>>> > Total noob, here. Taking my exams on Thursday. Got my TIDRADIO UV-5R and the FTDI cable. How can I detect which /dev/tty is being used for the FTDI connection to my radio? I tried /dev/ttyS0 and /dev/ttyUSB0 which resulted in the error 'Radio did not respond'.
>>>>>>>>> >
>>>>>>>>> > Kindly,
>>>>>>>>> >
>>>>>>>>> > Robert
>>>>>>>>> >
>>>>>>>>> > . .. ... ‘...^,^
>>>>>>>>> >
>>>> _______________________________________________
>>>> chirp_users mailing list
>>>> chirp_users at intrepid.danplanet.com
>>>> http://intrepid.danplanet.com/mailman/listinfo/chirp_users
>>>> This message was sent to Paul AC0HY at
>>>> ac0hy at wpmills.com
>>>> To unsubscribe, send an email to
>>>> chirp_users-unsubscribe at intrepid.danplanet.com
>>> --
>>> /**************************************************
>>> * Amateur Radio Station AC0HY                     *
>>> * W. Paul Mills         SN807                     *
>>> * Assistant EC Alpha-1 ARES Shawnee/Wabaunsee, KS *
>>> * President Kaw Valley Amateur Radio Club         *
>>> **************************************************/
>>> _______________________________________________ chirp_users mailing list chirp_users at intrepid.danplanet.com http://intrepid.danplanet.com/mailman/listinfo/chirp_users This message was sent to Robert Withers at robert.withers at pm.me To unsubscribe, send an email to chirp_users-unsubscribe at intrepid.danplanet.com
>> _______________________________________________
>> chirp_users mailing list
>> chirp_users at intrepid.danplanet.com
>> http://intrepid.danplanet.com/mailman/listinfo/chirp_users
>> This message was sent to Chuck Hast at kp4djt at gmail.com
>> To unsubscribe, send an email to chirp_users-unsubscribe at intrepid.danplanet.com
> --
> Chirp + Editcp + MD380Tools on Linux
> Celestial!!!
> Chuck -- KP4DJT
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20210409/d17d7e06/attachment.html 

More information about the chirp_users mailing list