[chirp_users] "length 0" error DLing from FT-8900

Charles Boling (AD7UF)
Sat Jun 13 06:54:42 PDT 2015

A final (at least for now) report on this:

I tried the another cable, and it likewise exhibited the problem on the
one machine but not the others.  Just for grins, I installed the
appropriate Windows driver (which, also worked fine on other hardware)
in a VM with the device connected to it (as a raw USB device, not as a
COM port) and observed the same malfunction there, which assured me that
it wasn't an issue that was common between the PL2303 driver in all
versions of the Linux kernel and that particular chip on that particular
motherboard.).  The only thing I haven't done software-wise is try a
bare-metal install of Windows on that machine to disprove any general
problem specific to the kernel's generic USB driver (that only shows up
with this kind of cable, and not any of the other half-dozen other kinds
of Prolific cables & adapters I have, nor with the dozens of other kinds
of USB devices I've used with it).

So, for now I'm just going to have to use another machine to talk to the
radio.  If I *really* want to program on this machine, I might buy an
RS-232 cable, and try it with one of the USB/RS-232 converters I've used
w/ this box, and see if I have any better luck with that. And if I
happen to get my hands on a digital storage scope, I'd love to record
the communication at the radio port and compare the signals.

More information about the chirp_users mailing list