[chirp_users] Trying to use chirp via ser2net and socat

Nigel Johnson, MIEEE
Wed Nov 5 13:23:38 PST 2014

Hi, I wonder if anybody has tried this and can offer advice: I have chirp running on a laptop in my apt, but an FT8900 is in a boiler room one the roof.  The remote control head for the radio is down in the apartment.

I can connect to the FT8900 by running a ser2net service up there and socat down here.  With this setup and permissions all set OK using /dev/pts/5, I can see the FT8900 send a character when I put it into clone mode.  But chirp will not recognise anything and gives me "Failed to communicate with radio: Failed to read header (0)"
I am using SuSE linux here and CentOS upstairs.  I have tried setting the serial port up there to 1200, 4800, 9600 and 19200.  I assume that chirp uses autobauding to communicate with the radio but that is obviously not available over a tcp connection.

Any help would be appreciated!

73 de Nigel ve3id

Nigel Johnson

Amateur Radio, the origin of the open-source concept!


You can reach me by voice on Skype:  TILBURY2591

If time travel ever will be possible, it already is. Ask me again yesterday

This e-mail is not and cannot, by its nature, be confidential. En route from me to you, it will pass across the public Internet, easily readable by any number of system administrators along the way.
    Nigel Johnson <nw.johnson at ieee.org>

Please consider the environment when deciding if you really need to print this message

More information about the chirp_users mailing list