[chirp_users] Yaesu FT-60 upload fails but download works

Marcia Stockton
Sun May 26 10:16:27 PDT 2013

I could use some help figuring out how to make this work.  I have tried 
everything I could think of for 2 days before asking for help.

In summary, Chirp 0.3.1 and 0.1.12 will receive configuration data from 
the Yaesu FT-60 radio, but will not send chirp image data back to the 
radio to configure it.  Permissions on the serial device /dev/ttyS0 are 
correct:  crw-rw---- allowing the dialout group to read/write the serial 
port, and my userid is a member of the dialout group.

The steps I tried are listed below.  (Pardon me for the length of the 
problem-solving narrative but I decided to include  a number of false 
steps and time-consuming problems due to incomplete or erroneous or 
confusing documentation, in case these are fixable issues, so that 
others might avoid these troubles.)

Thanks for any help you can give.

Marcia NU6N

----------------Tried to Solve the Problem Myself------------------

OS = Linux Mint 12

First, installed chirp package from Ubuntu ppa repository (Linux Mint is 
a Ubuntu derivative and Ubuntu packages almost always work fine): |

sudo apt-add-repository ppa:ubuntu-hams-updates/ppa sudo apt-get update 
sudo apt-get install chirp|

What I got was a downlevel chirp 0.1.12.  Tested it and chirp 0.1.12 
successfully read from the radio.

The problem occurs repeatably whenever I try to upload from chirp to the 
radio.  The cable should be OK because it was purchased from Yaesu and 
has worked before in both directions with Yaesu-provided rig programming 
software on the same laptop, back when we ran Windows on this laptop.  
The serial port on the laptop works fine when communicating with the HF 

And one should try the latest version before asking for help, as the 
Yaesu FT-60 support might be more complete in the current version, based 
on differences in the test reports for the two versions ("Test report 
for CHIRP version 0.1.12"  
(http://chirp.danplanet.com/download/0.1.12/Test_Report.html shows all 
functions supported on FT-60 except "clone"; whereas clone is listed as  
supported on the current beta release 0.3.1 

I downloaded the 0.3.1 tarball and manually installed it (|sudo python 
setup.py install)|.  I presumed that the necessary libraries were 
already present as a result of the previous installation of chirp 
0.1.12.  The manual installation ||produced error messages and chirpw 
would not run (i.e. was not installed in a way that allowed it to be run 
from any directory or menu.)

However, per the instructions, running chirp 0.3.1 directly from the 
directory it was unzipped to, via ./chirpw command, worked OK ... except 
that upload to radio still didn't work.

To rule out the possibility of a conflict with code that could have been 
left over from the 0.1.12 install, I removed chirp 0.1.12 using apt-get 
remove chirp.  Then I manually deleted all files and directories that 
had been created by the attempted manual install of chirp 0.3.1. ||

So at this point I am starting over attempting a clean manual install of 
chirp 0.3.1 from the downloaded tarball.  Following the instructions at 
to ensure all prerequisite libraries are present,

sudo apt-get install python-gtk python-serial python-libxml2

produced an error message:  Package 'python-gtk' has no installation 

I ran apt-get update but still no python-gtk.  I then ran a complete 
sudo apt-get upgrade on my system to ensure all my repository-provided 
software is up to date.

After web research I learned there is no longer a python-gtk but there 
is a python-gtk2, and it is already installed on my system, and is the 
newest version.

I unpacked chirp 0.3.1 and again ran chirp from inside the directory 
where it was unpacked.  (Did not attempt to run the python installer 
this time.)

Again chirp 0.3.1 ran, with the same results as before:  Chirp can 
receive data from the FT-60 radio, but when data from chirp cannot be 
sent to the radio.

Note that I carefully followed the special sequence instructions 
required for Yaesu radios, always putting the receiving device into 
receive mode first, before initiating transmit on the other device. 
Thus, when attempting to send a couple of memories from chirp to the 
radio, I did the following, which I believe was correct:

a. Put the FT-60 into clone mode with the cable connected to the mic/sp 
port, by powering on while holding the MONI button.  Turn the large knob 
until 'F8 CLONE' appears.  Press F/W key.  Radio restarts displaying 
CLONE.  Put radio into Rx mode by pressing MONI.  Radio displays 
---Rx--- and waits to receive data from chirp.

b.  On Chirp, select Radio then Upload to Radio.  The port, vendor and 
model are set to the same values that work for receiving data from the 
radio, i.e.:
/dev/ttyS0, Yaesu, FT-60.  Click OK to begin transmitting to the radio.

c.  Chirp's prompt appears showing that Chirp is attempting to transmit 
to the radio.  After a short timeout, error message appears:
"An error has occurred.  Failed to communicate with radio:  Radio did 
not respond."  (Note that the radio still displays ---Rx--- ).

Chirp Help, About shows the following:

Chirp 0.3.1
GTK 2.24.6
PyGTK 2.24.0
Python 2.7.2+


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20130526/a8c5d136/attachment.html 

More information about the chirp_users mailing list