[chirp_users] Getting Started w/ CHIRP on Mac OS X using Kenwood TH-F6 & FTDI cable

Milton Hywatt
Sat Aug 31 14:11:05 PDT 2013

The radio has settings in the Tuning portion of it's menu system.
It must be on PC. Press Menu, turn the encoder knob to Tuning
and the default selection is sp/mic. I don't own one of these radios
just reading from the instruction manual on page 46. However you
can change those selection you need to change it to PC. 

 From: GaryErrol <garyerrol at comcast.net>
To: Discussion of CHIRP <chirp_users at intrepid.danplanet.com> 
Sent: Saturday, August 31, 2013 4:42 PM
Subject: Re: [chirp_users] Getting Started w/ CHIRP on Mac OS X	using	Kenwood TH-F6 & FTDI cable

It depends on which radio but on most it is turn the radio, with cable attached,  on and you're in programming mode. 

-------Original Message-------
From: Robert Gendreau [rob.gendreau at gmail.com]
Date: Sat, Aug 31, 2013
To: Discussion of CHIRP [chirp_users at intrepid.danplanet.com]
Reply To: Discussion of CHIRP [chirp_users at intrepid.danplanet.com]
Subject: Re: [chirp_users] Getting Started w/ CHIRP on Mac OS X using    Kenwood TH-F6 & FTDI cable

It looks like everything is OK on the computer/cable end; waiting for data seemed to be  the hangup. I don't have a Kenwood radio, but on most you need to do something on the radio end to get it into a mode so it will send serial programming data. On my FT60 it's something like turning it on while depressing MON, then switching to a certain menu, and so on. What is it for Kenwood?

On Aug 31, 2013, at 1:14 PM, Dave Nathanson <kg6zjo.lists at nathanson.org> wrote:

> Hi, 
> I'm having a problem getting started with CHIRP 0.3.1, I have never used CHIRP before. 
> I bought the usb to FTDI cable from Valley Enterprises last week. part# Kenwood USB KPG-22 FTDI as recommended 
> http://chirp.danplanet.com/projects/chirp/wiki/CableGuide
> I installed the 64 bit version of the FTDI drivers ( FTDIUSBSerialDriver_v2_2_18.dmg ), and when I had problems, I also installed the D2XX drivers. 
> http://www.ftdichip.com/Drivers/VCP.htm
> http://www.ftdichip.com/Drivers/D2XX.htm
> I also installed the Python runtime. ( KK7DS_Python_Runtime_R10.pkg ) from
> http://www.d-rats.com/download/OSX_Runtime/
> Rebooted after installing the drivers & libs. 
> My computer is running Mac OS X 10.8.4. I'm a long time Mac guy, always open to learning from everybody. Before posting I have searched around & dug through several months of list archives. So hopefully I am giving you guys good info to help me. I apologize for the length of this message. 
> To begin, I turn the radio on (Kenwood TH-F6) and plug in the FTDI cable between the radio & the computer. 
> When I launch CHIRP, it opens with a blank window. I can pull the menu to "Download from Radio" then it asks me to select the port, make & model of radio. 
> Screen pictures:
> http://nathanson.org/Dave/CHIRP.danplanet/MacOSX_SystemProfile_Showing_FTDI.png
> http://nathanson.org/Dave/CHIRP.danplanet/CHIRP_choose_port_and_radio.png
> http://nathanson.org/Dave/CHIRP.danplanet/CHIRP_blank_window.png
> When I click the OK button, the radio light flashes once, as if the ptt was quickly pressed, the main window flashes once and nothing else happens. Still a blank window. It does not ask me where I would like to save anything. THe radio doesn't seem to be doing anything either. 
> When I plug in the cable first, then power on the radio, it goes to the 2 line A/B display with a memory name repeater on the bottom line & blinking PF# on the top line. This also locks the keypad. You can't even power off without unplugging the cable. CHIRP does the same thing, regardless. That is it displays the dialog box for what port, then the CHRIP window dims briefly then comes back as front window in a couple of seconds. 
> I downloaded the daily build just in case, but it does the same thing. 
> If I disconnect the FTDI cable, before launching CHIRP & trying to download from radio, then CHIRP reports the port does not exist. So that seems to indicate that the drivers are installed since it only gets that error when the cable is disconnected. I have tried plugging the FTDI cable into both the keyboard hub and directly into the computer. No difference. If I open Terminal and type:
> dnathanson:~ david$ ls /dev/cu*
> /dev/cu.Bluetooth-Modem
> /dev/cu.Bluetooth-PDA-Sync
> /dev/cu.DavePalm-Dial-upnetwork-1
> /dev/cu.Louise-Dial-upnetworking-1
> /dev/cu.usbserial-A501XQ5I
> if I type kextstat it returns a whole page list of kexts, including this one at the bottom:
>  142    0 0xffffff7f81fc8000 0x8000     0x8000     com.FTDI.driver.FTDIUSBSerialDriver (2.2.18) <112 32 5 4 3 1>
> I also have the FTDI cable for a Yaesu radio, which I have not tried yet. 
> I looked at the log (~/.chirp/debug.log), here is the bottom of it: 
> Registered Wouxun_KG816 = KG816Radio
> Icon /usr/share/pixmaps/chirp.png not found
> Initialized MacOS support
> /Applications/chirp-0.3.1.app/Contents/MacOS/../Resources/chirp/chirpw:128: PangoWarning: error opening config file '../Resources/etc/pango/pangorc': No such file or directory
>  a.show()
> User selecte
chirp_users mailing list
chirp_users at intrepid.danplanet.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20130831/4cbc2faa/attachment.html 

More information about the chirp_users mailing list