[chirp_users] Flatpak

D.J.J. Ring, Jr. n1ea at arrl.net
Thu Jun 2 13:24:07 PDT 2022


On Thu, Jun 2, 2022 at 4:02 PM David Ranch <chirp at trinnet.net> wrote:
>
> I just looked on the Chirp website, Wiki, and FAQ and only the download page gives a hit that Linux users should use the Flatpak method.  Beyond that.. no details are shared.
>
> Could someone who has access to the web page take what D.J.J wrote down below and add it to a "Linux Flatpak" FAQ entry?  It might need some additional items listed under a dependency section like the native OS needs to have X version of Qt runtime libraries installed, etc.
>
> --David
> KI6ZHD

DE N1EA

I have qt5 and qtatspi installed.

qt5 (a multi-platform C++ graphical user interface toolkit)
qtatspi [Installed]: qtatspi (Qt AT-SPI2 bridge.) QT Accessibility
Bridge to SPI2. At-Spi2 is a protocol over DBus, toolkit widgets use
it to provide their content to screen readers such as Orca.

I am using Slint Slackware 14 with orca 41.1 running and CHIRP is
inaccessible to blind users as ORCA doesn't read the screen.

I highly recommend SLINT which is International (supports lots of
languages and is highly accessible with multiple console screen
readers and text applications already installed and more are
available. https://slint.fr/wiki/doku.php?id=:en:start

73
DR


More information about the chirp_users mailing list