[chirp_users] CHIRP support for MacOS/Prolific

Jim Unroe rock.unroe at gmail.com
Tue Feb 8 13:20:57 PST 2022


On Tue, Feb 8, 2022 at 4:06 PM Gary Ross <garyrvt at gmail.com> wrote:
>
> Hi,
>
> Just received a Yaesu FT-65R and a genuine SCU-35 programing cable (Prolific PL2303). I tried programming my radio with CHIRP4 on Monterey 12.1 on a 2020 MacBook Air, and CHIRP3 on Catalina 10.15 on a 2017 MacBook Air and receive an error with both configurations.

What do you mean by CHIRP4 and CHIRP3? The very old "stable" builds
(v0.4.x and v0.3.x from 2014 and before)? These should not be used.
Today it is recommended that you download and install the MacOS
Unified Application.

> Having received the error, I tried to install the Prolific driver found here: http://www.prolific.com.tw/us/showproduct.aspx?p_id=229&pcid=41 I am unclear if the driver was needed or installed correctly.

The drivers written by the Prolific company have dropped support for
the older PL2303 XA chip that many generic programming cables use. To
get around this issue with Windows you can simply download, install
and select the older Prolific v3.2.0.0 driver. It isn't that easy with
macOS.

What I did here to get around the issue was to purchase a Prolific
driver from a 3rd party developer (https://www.mac-usb-serial.com/).
The driver is not free, but it has been discounted 42% for quite some
time for €6.90 (which was $9.11 when I purchased it).

> Does anyone have experience with later versions of MacOS/CHIRP/FT-65R?

I don't have an FT-65R.

> Thanks,
> Gary

Jim KC9HI


More information about the chirp_users mailing list