[chirp_users] Suddenly, cannot connect to GT-3TP from latest CHIRP or previous versions

Jim Unroe rock.unroe at gmail.com
Mon May 24 10:15:15 PDT 2021


On Mon, May 24, 2021 at 11:25 AM Ceferino Lamb <ceferino.lamb at gmail.com> wrote:
>
> For months, I've been successfully cloning GT-3TPs for our own use and UV5Rs for friends.
> Suddenly, last week, I can't connect to any radios via CHIRP. I've installed the most recent CHIRP versions. Today it's chirp-daily-20210520-installer.exe

This is not unusual with Windows and some programming cables with
Prolific type USB-to-Serial chips. If you previously had to install
and select the older Prolific v3.2.0.0 driver to get your programming
cable(s) to work, Windows can and will, without notice, update to the
latest driver version and sometimes even remove the working driver.
When this happens your programming cable will not function until you
install and select the older driver again.

>
> I have two known good cloning cables that worked previously. Same results. I'm using BF-F8HP type as always.  I've tried two different COM ports, CHIRP sees both.

With Windows, there is no need to "try" different COM ports. You
should use the Windows Device Manager application to determine exactly
which COM port has been assigned to the programming cable.

>
> The first time I tried this morning,  Upload to Radio keyed the trx on the HT, solid carrier until I turned the HT off. That's a clue to me that something odd is up.

Causing a radio to go into transmit is an indication that either or
more of the following are true...
1 the USB end of the programming cable is not plugged into the computer
2 the USB end of the programming cable is plugged into the computer
but the device driver has not been loaded yet
3 the USB end of the programming cable is plugged into the computer
but the device driver that is loaded is not compatible with the chip
in the programming

The #3 cause above is most often the result when the programming cable
was manufactured with an unauthorized copy (counterfeit) of the
Prolific PL2303HXA USB-to-serial chip. Driver versions after
v3.3.2.105 are intentionally designed to be incompatible with these
unauthorized chip copies. So if someone or something upgrades a
Prolific driver to the latest Windows version, any programming cables
with a counterfeit Prolific chip will stop functioning.

Since the majority of my 20+ programming cables that I have these
unauthorized Prolific chip copies and I have been using them with
Windows since getting my USB based programming cable back in 2012, I
have been using the Prolific v3.2.0.0 driver with Windows 7, 8.1 and
10 (v2.0.2.1 for Windows XP) to program my radios. When Windows on its
own updates the driver, my programming cable stop working until I
install and select the older v3.2.0.0 driver again.

None of my programming cables with USB-to-Serial chips from other chip
vendors (FTDI, Silicon Labs, WCH, etc) have this issue. So switching
to a programming cable with a chip from a different chip vendor is
also a solution if you want to avoid having to go through this again
in the future.

>
> My next step is to install CHIRP on a different W10 laptop and try there.  Anybody BTDT?

No programming cable can work without a complete and working
connection between the radio and computer. It is the CHIRP user that
must insure that this connection is complete and working.

>
> Reno in Texas
> Quis custodiet ipsos custodes?

Jim KC9HI


More information about the chirp_users mailing list