[chirp_users] Fail Install CHIRP on Slackware

D.J.J. Ring, Jr. n1ea at arrl.net
Sun May 9 15:28:33 PDT 2021


I found  a new package which somehow didn't automatically install when
upgrading.

https://slackware.pkgs.org/14.2/slackware-x86_64/libxml2-2.9.4-x86_64-2.txz.html

I use /tmp in root file space to install such programs.

su -
give root password

# cd /tmp

Using wget to get the new files.

wget
https://slackware.uk/slackware/slackware64-14.2/slackware64/l/libxml2-2.9.4-x86_64-2.txz

Then I upgrade the existing package.

upgradepkg --install-new libxml2-2.9.4-x86_64-2.txz

Then I install chirp.

spi --install chirp

Installing new package ./chirp-20201128-x86_64-1_SBo.txz

Then I run chirpw and chirp works. It does nag me about a newer version
being available, but I ignored that message and I'll wait for it to appear
in the Slackware  repository.

Problem solved!

73
DR
N1EA



On Sun, May 9, 2021 at 6:13 PM D.J.J. Ring, Jr. <n1ea at arrl.net> wrote:

> Hello Discussion,
>
> Running SLINT, Slackware International, based on Slackware 14.2.
>
> I cannot install chirp because there is no libxml2mod.
>
> ImportError: No module named libxml2mod
> fakeroot -- sh chirp.SlackBuild Failed
>
> Full errors:
>
> No handlers could be found for logger "chirp.drivers.anytone778uv"
> Traceback (most recent call last):
>   File "setup.py", line 6, in <module>
>     from chirp.drivers import *
>   File
> "/usr/src/slapt-src/ham/chirp/chirp-daily-20201128/chirp/drivers/generic_xml.py",
> line 17, in <module>
>     import libxml2
>   File "/usr/lib64/python2.7/site-packages/libxml2.py", line 1, in <module>
> ImportError: No module named libxml2mod
> fakeroot -- sh chirp.SlackBuild Failed
>
> I don't know who works on the slackware build of chirp.
>
> Thanks,
> David N1EA
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20210509/77c347a6/attachment.html 


More information about the chirp_users mailing list