[chirp_users] " Python-future package" on Mac;

Martin Cooper mfncooper at gmail.com
Thu Jun 17 19:25:16 PDT 2021


I have not tried this, so I don't know if it would work, but if you put the
'future' package in the right place inside the application, it seems like
it should work, since Chirp is unsigned. That is, copy the 'future' package
you just installed from your global Python site-packages directory to:

[wherever-you-put-the-chirp-application]/CHIRP.app/Contents/Resources/site-packages/

Again, I haven't tried it, but if you're willing to fiddle around a bit,
you could try it and see what happens.

Martin.
KD6YAM

On Thu, Jun 17, 2021 at 6:09 PM Craig Hayes via chirp_users <
chirp_users at intrepid.danplanet.com> wrote:

> Hello,
>
> I’m having trouble with Chirp on my Mac  ( 10.13 High Sierra but same
> problem on Mojave ) and my new Anytone AT-778UV VOX.
>
> The radio model is not in the drop down menu. If I launch Chirp from the
> shell script I get this warning in the terminal;
>
> WARNING: python-future package is not available;
> chirp.drivers.anytone778uv requires it
>
> I guess this explains why I don’t see the radio entry in the menu.
>
> I tried installing future via pip, everything appeared to work but still
> no luck.
>
> Anybody encounter this problem? Any hints on where to look for a solution?
>
> Thanks,
>
> Craig
> _______________________________________________
> chirp_users mailing list
> chirp_users at intrepid.danplanet.com
> http://intrepid.danplanet.com/mailman/listinfo/chirp_users
> This message was sent to Martin Cooper at mfncooper at gmail.com
> To unsubscribe, send an email to
> chirp_users-unsubscribe at intrepid.danplanet.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20210617/224e010b/attachment.html 


More information about the chirp_users mailing list