[chirp_users] Download From Radio under Ubuntu 20.04 error

Robert Withers
Wed Apr 7 13:15:51 PDT 2021

I will look into this. In the meantime, as I do not know which email to hang this news off of, I will put it here. Here is a (4 star for some reason) comment on the FTDI cable I bought: https://www.amazon.com/product-reviews/B015YEM5C2/ref=acr_dp_hist_4?ie=UTF8&filterByStar=four_star&reviewerType=all_reviews#reviews-filter-bar

> I bought this cable after many, many owners of the Baofeng radios stated to purchase the more expensive cable over the lesser priced cables. My experience was interesting, many owners of these types of cables stated that "they just work with linux with no additional software or support." (besides Chirp) and frankly as a Linux user that's what drew me to this product. Long story short, this did not work with Chirp in Linux, even after updating to the newest version of Chirp. I even downloaded and created a Chirp Live CD. That did not work either.

ANd so I have ordered a different FTDI cable now: BTECH PC03 FTDI Genuine USB Programming Cable for BTECH, BaoFeng, Kenwood, and AnyTone Radio. The description states:

> Drivers are available which allow FTDI devices to work with the following operating systems: Windows, Max OSX, and Linux

Thank you for all of the responses! I will try to install python-future, per your instructions, although pip says it is already installed.

On 4/7/21 4:06 PM, wa0sbu at kslimmer.com wrote:

> Download it.
> ["https://packages.ubuntu.com/bionic/all/python-future/download"](https://packages.ubuntu.com/bionic/all/python-future/download)
> "sudo dpkg -i python-future_0.15.2-4ubuntu2_all.deb"
> On 4/7/21 2:15 PM, Robert Withers via chirp_users wrote:
>> I ran this command, found on web to install python-future, as the apt install command was unable to locate package python-future.
>>> rabbit at ganymede:~$ pip install future
>>> Defaulting to user installation because normal site-packages is not writeable
>>> Requirement already satisfied: future in /usr/lib/python3/dist-packages (0.18.2)
>>> WARNING: You are using pip version 20.2.4; however, version 21.0.1 is available.
>>> You should consider upgrading via the '/usr/bin/python3 -m pip install --upgrade pip' command.
>> I ran the two commands you specified. The output is attached. In the syslog file, the first 3 lines are unplug, the rest are due to replugging in the FTDI cable. Here seems to be the pertinent line from syslog;
>>> Apr 7 15:06:08 ganymede ModemManager[1098]: <info> Couldn't check support for device '/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1/1-1.1.3': not supported by any plugin
>> Not sure what move to make now.
>> Kindly,
>> Robert
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20210407/82a1f02b/attachment.html 

More information about the chirp_users mailing list