[chirp_users] Fw: No USB Port Error

Glenn K0LNY glennervin at cableone.net
Wed Jun 3 10:05:38 PDT 2020


I think that chmod 777 is a useful command for certain problems, but apparently not this one.
This cable works on my Baofeng 8HP, and it is supposed to work for both Kenwood and Baofeng.
I hope it isn't a problem with the radio, I just got it used.
I set it to the defaults, but I haven't found any documentation indicating that there needs to be a setting made on the Kenwood to work with a programming cable.
I made sure that there was nothing on the channel when I connected the cable.
Glenn
----- Original Message ----- 
From: Pat Anderson 
To: Discussion of CHIRP 
Sent: Wednesday, June 03, 2020 11:58 AM
Subject: Re: [chirp_users] Fw: No USB Port Error


So, after starting CHIRP, you dropped to a terminal and did the "sudo chmod 777 /dev/ttyUSB1" command? I think the /dev/ttyUSB0 or /dev/ttyUSB1 probably just depends on which USB port the cable is plugged into. I always use the one on the left so mine is  always /dev/ttyUSB0. But it needs to be made readable and writable with the chmod, and that needs to done with sudo. If you did that, I am very surprised that did not work for you!


On Wed, Jun 3, 2020 at 9:38 AM Glenn K0LNY <glennervin at cableone.net> wrote:

  Hi Pat,
  On the computer that I got the lsusb info from, the cable is using /dev/ttyUSB1
  I did as you suggested using 1 instead of 0 and it accepted the command, but in my case, it did not help.
  Thanks though.
  Glenn
  ----- Original Message ----- 
  From: Pat Anderson 
  To: Discussion of CHIRP 
  Sent: Wednesday, June 03, 2020 11:14 AM
  Subject: Re: [chirp_users] Fw: No USB Port Error


  Windows is fussy about the chip in the programming cable. Dan's advice to use real FTDI cables for Windows is absolutely correct. For Linux, it does not make any difference, cheap fake Prolific cables work great once you use chmod to make the device readable and writable. 


  Pat Anderson
  KD7OAC


  On Wed, Jun 3, 2020 at 8:29 AM Glenn K0LNY <glennervin at cableone.net> wrote:

    I found this on the Chirp site, which indicates that the Kenwood TH-F6 requires the two prong plug, which is the one I used, and it further states that the cord for the Baofeng should work on the Kenwood TH-F6, at least in Linux.
    https://chirp.danplanet.com/projects/chirp/wiki/CableGuide
    Kenwood Radios
    TH-F6A, TH-K2A

    These radios use a two-pronged cable that plugs into the microphone and speaker jacks simultaneously. Note: many Chinese radios such as the Wouxun, and
    Baofeng UV-5R use the same two prong cable as these Kenwoods.

    Build your own cables: 
    list of 1 items
    • Miklor Site's Baofeng DIY
     (The UV-5R cable will work for these Kenwood)
    list end

    ----- Original Message ----- 
    From: Glenn K0LNY 
    To: Jardy Dawson ; Discussion of CHIRP 
    Sent: Wednesday, June 03, 2020 10:11 AM
    Subject: Re: [chirp_users] Fw: No USB Port Error


    How does one go about doing virtual com ports in Linux?
    In windows, I have a lot of them.
    But I can really only use Chirp in Linux, as it is doable in windows, but difficult in Windows when it is working right, because of the fact that Chirp in Windows does not work well with a screenreader, I would not want to try and figure this out in Windows.
    I mainly use windows, and only boot to Linux for things like using Chirp, or working with disk partitions and the like.
    But since Chirp worked as normal in Linux with the new cable and my Baofeng, I know that the cable is working and Chirp is working.
    This cable has a plug in that resembles a headphone plug and a variety of different cords for different radios.
    One of the ones that worked for the Baofeng has two tips as the Baofeng cable does, but there is only one other cable with two tips and that fits neither radio.
    The other tips only have one plug a couple of which are too small to fit in the bigger jack.
    I guess I didn't try the smaller tips in the smaller of the Kenwood jack.
    Maybe the smaller plug on the radio is the important one?
    The cables aren't labeled, so I had to try them and see if they work.
    Has anyone here used a cable for a Kenwood TH-F6 with only one plug?
    Glenn
    Glenn
    ----- Original Message ----- 
    From: Jardy Dawson via chirp_users 
    To: Discussion of CHIRP 
    Sent: Wednesday, June 03, 2020 1:41 AM
    Subject: Re: [chirp_users] Fw: No USB Port Error


    A lot of Kenwood need to have “virtual comm ports” installed. You might want to check the Kenwood web site to see if that is the case here. 


    Jardy Dawson WA7JRD 
    Message sent through sub space hailing frequencies using the Universal Translator. 




      On Jun 2, 2020, at 23:38, Glenn K0LNY <glennervin at cableone.net> wrote:


       
      Well this cable was advertised to work with Kenwood, but it doesn't.
      I tried one of the supplied cables and it worked okay with my Baofeng.
      And then again none of the cables worked on the Kenwood.
      Looks like I need to get another cable, and Chirp isn't the problem.

      ----- Original Message ----- 
      From: D.J.J. Ring, Jr. 
      To: Discussion of CHIRP 
      Sent: Tuesday, June 02, 2020 11:56 PM
      Subject: Re: [chirp_users] Fw: No USB Port Error


      Glen,


      With the USB device plugged in, use a terminal and enter this:


      lsusb 


      Carefully check the names of the devices. Is it really /dev/USB1 ?


      Remember Unix / Linux is case sensitive, /dev/USB1 is  NOT /dev/usb1 which is a normal device name.


      Let's assume you made an error and the device is ttyUSB1.


      In terminal:
      ls -l /dev/ttyUSB1


      Pay attention to the group this device belongs, to. The owner will be root.


      You need to be in the same group to access it.


      Find out what groups your user account is in by the command "groups."


      In terminal enter:


      groups


      Is the group that ttyUSB1 belongs to listed as one of your groups? If not you have to add your user to that group using the root account.


      Best wishes,


      David
      N1EA 





      On Wed, Jun 3, 2020, 00:10 Glenn K0LNY <glennervin at cableone.net> wrote:

        Well, I made a little progress with the USB problem, in Ubuntu.
        I installed a new live Ubuntu, on a thumb drive for a friend, and I 
        installed Chirp for him, and plugged in my Kenwood and tried to download 
        from radio, and first it did nothing.
        So I tried again, and I got the same error:
        error no 2 cannot find ttyUSB0
        No such file or directory.
        And this was on a fresh install of Ubuntu 16.43 with updates installed.
        Just like on my other computer that had the same issue.
        So in doing a web search on the problem, I found a YouTube where the guy 
        suggested using lsusb and he found the device in his case, on USB1.
        So I went to terminal and found the prolific on USB1
        So then I found that in Chirp, it wasn't there before, I am fairly sure.
        So now I no longer get that error, but it still does not download from the 
        radio, it just goes to the blank Chirp screen.
        Any ideas?

        Thanks in advance.
        Glenn
        ----- Original Message ----- 
        From: "Glenn K0LNY" <glennervin at cableone.net>
        To: "Discussion of CHIRP" <chirp_users at intrepid.danplanet.com>
        Sent: Friday, May 22, 2020 5:03 PM
        Subject: Re: [chirp_users] No USB Port Error


        Jim,
        I just checked to add ubuntu-mate to the dialout and it tells me that
        ubuntu-mate is already a member of dialout.
        So there is a problem with it finding usb0.
        Could it be that a different radio's cable might be using a serial
        assignment?
        I've used the Tytera cable via USB and Baofeng's cable via USB and it has
        always been recognized.
        Note, the cable I'm stuck with for now is a USB cable that should go with a
        digital radio, the Radioddity GD77-S, so I don't know if it has something
        different to the cable.
        I accidentally sent the Baofeng cable along with the GD77-S that I traded
        for the Kenwood.
        Glenn

        ----- Original Message ----- 
        From: "Jim Unroe" <rock.unroe at gmail.com>
        To: "Discussion of CHIRP" <chirp_users at intrepid.danplanet.com>
        Sent: Friday, May 22, 2020 12:51 PM
        Subject: Re: [chirp_users] No USB Port Error


        On Fri, May 22, 2020 at 1:06 PM Glenn K0LNY <glennervin at cableone.net> wrote:
        >
        > Hi,
        > I just got a new used radio, a Kenwood TH-F6.
        > So I plugged in the radio using a non-Kenwood cable and I went into
        > "radio" and download from radio and selected my radio model and USB0 and I
        > get the message:
        > error no 2 cannot open tty/usb0 error cannot locate tty/USB0.
        > or something similar.
        > I have used this cable and that Ubuntu with Chirp in the past for my other
        > radios, and other than different brands of radios, I have always been able
        > to do this.
        > I know a guy who has done this to this model using the Baofeng cable using
        > a different software in Windows, not the Kenwood software, but one that
        > they purchased.
        > I don't recall the name, but I think it starts with an R.
        > At any rate, I'd sooner buy a Kenwood cable than that other software and
        > keep using Chirp.
        > Hopefully I didn't get it mixed up with the Radioddity cable.
        > I thought I had the right cable with the Radioddity when I sent it off.
        > I don't know if they put the name of the associated radio on the cables,
        > since I'm Blind.
        > But any who, would this be an error for the wrong cable?
        > Thanks.
        > Glenn

        Hi Glenn,

        >From what you are describing it sounds like you Linux user doen't have
        permission to access the port. Either run CHIRP as root or as your
        Linus user to the dialout group.

        I also have a Kenwood TH-F6a. CHIRP programs it in "live" mode.

        Jim KC9HI
        _______________________________________________
        chirp_users mailing list
        chirp_users at intrepid.danplanet.com
        http://intrepid.danplanet.com/mailman/listinfo/chirp_users
        This message was sent to Glenn at glennervin at cableone.net
        To unsubscribe, send an email to
        chirp_users-unsubscribe at intrepid.danplanet.com

        _______________________________________________
        chirp_users mailing list
        chirp_users at intrepid.danplanet.com
        http://intrepid.danplanet.com/mailman/listinfo/chirp_users
        This message was sent to D.J.J. Ring, Jr. at n1ea at arrl.net
        To unsubscribe, send an email to chirp_users-unsubscribe at intrepid.danplanet.com



--------------------------------------------------------------------------


      _______________________________________________
      chirp_users mailing list
      chirp_users at intrepid.danplanet.com
      http://intrepid.danplanet.com/mailman/listinfo/chirp_users
      This message was sent to Glenn at glennervin at cableone.net
      To unsubscribe, send an email to chirp_users-unsubscribe at intrepid.danplanet.com _______________________________________________
      chirp_users mailing list
      chirp_users at intrepid.danplanet.com
      http://intrepid.danplanet.com/mailman/listinfo/chirp_users
      This message was sent to Jardy at jardy72 at yahoo.com
      To unsubscribe, send an email to chirp_users-unsubscribe at intrepid.danplanet.com


----------------------------------------------------------------------------


    _______________________________________________
    chirp_users mailing list
    chirp_users at intrepid.danplanet.com
    http://intrepid.danplanet.com/mailman/listinfo/chirp_users
    This message was sent to Glenn at glennervin at cableone.net
    To unsubscribe, send an email to chirp_users-unsubscribe at intrepid.danplanet.com 


----------------------------------------------------------------------------


    _______________________________________________
    chirp_users mailing list
    chirp_users at intrepid.danplanet.com
    http://intrepid.danplanet.com/mailman/listinfo/chirp_users
    This message was sent to Glenn at glennervin at cableone.net
    To unsubscribe, send an email to chirp_users-unsubscribe at intrepid.danplanet.com 


    _______________________________________________
    chirp_users mailing list
    chirp_users at intrepid.danplanet.com
    http://intrepid.danplanet.com/mailman/listinfo/chirp_users
    This message was sent to Pat Anderson at anderson5420 at gmail.com
    To unsubscribe, send an email to chirp_users-unsubscribe at intrepid.danplanet.com


------------------------------------------------------------------------------


  _______________________________________________
  chirp_users mailing list
  chirp_users at intrepid.danplanet.com
  http://intrepid.danplanet.com/mailman/listinfo/chirp_users
  This message was sent to Glenn at glennervin at cableone.net
  To unsubscribe, send an email to chirp_users-unsubscribe at intrepid.danplanet.com

  _______________________________________________
  chirp_users mailing list
  chirp_users at intrepid.danplanet.com
  http://intrepid.danplanet.com/mailman/listinfo/chirp_users
  This message was sent to Pat Anderson at anderson5420 at gmail.com
  To unsubscribe, send an email to chirp_users-unsubscribe at intrepid.danplanet.com


--------------------------------------------------------------------------------


_______________________________________________
chirp_users mailing list
chirp_users at intrepid.danplanet.com
http://intrepid.danplanet.com/mailman/listinfo/chirp_users
This message was sent to Glenn at glennervin at cableone.net
To unsubscribe, send an email to chirp_users-unsubscribe at intrepid.danplanet.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20200603/e6562fee/attachment-0002.html 


More information about the chirp_users mailing list