[chirp_users] Fw: No USB Port Error

Glenn K0LNY glennervin at cableone.net
Wed Jun 3 03:21:03 PDT 2020


Well, it doesn't matter then, because neither works.
I wonder if something changed in Chirp, this always worked for me before.
Glenn

----- Original Message ----- 
From: D.J.J. Ring, Jr. 
To: Discussion of CHIRP 
Sent: Wednesday, June 03, 2020 12:16 AM
Subject: Re: [chirp_users] Fw: No USB Port Error


In your message you said:


"he found the device in his case, on USB1."


That's not a complete location, give the complete path.


We have to guess what you mean which is unsatisfactory when it comes to computers which are always exactly literal. 


Since you're taking about a tty device it's probably ls -l /dev/ttyUSB1 but next time you reboot it might go back to ls -l /dev/ttyUSB0 which is the usual assignment but your computer will go to ls -l /dev/ttyUSB1 if it still thinks ls -l /dev/ttyUSB0 is being used (occupied).


73


DR


On Wed, Jun 3, 2020, 01:07 Glenn K0LNY <glennervin at cableone.net> wrote:

  Hi David,
  I originally used lsusb
  Whatever I wrote in my message, in the commands I don't capitalize.
  When I added ubuntu-mate to dialout with addgroup it told  
  me that ubuntu-mate was already a user.
  But I'll try 
  ls -l /dev/ttyUSB1
  and see what that tells me.
  Glenn

  ----- Original Message ----- 
  From: D.J.J. Ring, Jr. 
  To: Discussion of CHIRP 
  Sent: Tuesday, June 02, 2020 11:56 PM
  Subject: Re: [chirp_users] Fw: No USB Port Error


  Glen,


  With the USB device plugged in, use a terminal and enter this:


  lsusb 


  Carefully check the names of the devices. Is it really /dev/USB1 ?


  Remember Unix / Linux is case sensitive, /dev/USB1 is  NOT /dev/usb1 which is a normal device name.


  Let's assume you made an error and the device is ttyUSB1.


  In terminal:
  ls -l /dev/ttyUSB1


  Pay attention to the group this device belongs, to. The owner will be root.


  You need to be in the same group to access it.


  Find out what groups your user account is in by the command "groups."


  In terminal enter:


  groups


  Is the group that ttyUSB1 belongs to listed as one of your groups? If not you have to add your user to that group using the root account.


  Best wishes,


  David
  N1EA 





  On Wed, Jun 3, 2020, 00:10 Glenn K0LNY <glennervin at cableone.net> wrote:

    Well, I made a little progress with the USB problem, in Ubuntu.
    I installed a new live Ubuntu, on a thumb drive for a friend, and I 
    installed Chirp for him, and plugged in my Kenwood and tried to download 
    from radio, and first it did nothing.
    So I tried again, and I got the same error:
    error no 2 cannot find ttyUSB0
    No such file or directory.
    And this was on a fresh install of Ubuntu 16.43 with updates installed.
    Just like on my other computer that had the same issue.
    So in doing a web search on the problem, I found a YouTube where the guy 
    suggested using lsusb and he found the device in his case, on USB1.
    So I went to terminal and found the prolific on USB1
    So then I found that in Chirp, it wasn't there before, I am fairly sure.
    So now I no longer get that error, but it still does not download from the 
    radio, it just goes to the blank Chirp screen.
    Any ideas?

    Thanks in advance.
    Glenn
    ----- Original Message ----- 
    From: "Glenn K0LNY" <glennervin at cableone.net>
    To: "Discussion of CHIRP" <chirp_users at intrepid.danplanet.com>
    Sent: Friday, May 22, 2020 5:03 PM
    Subject: Re: [chirp_users] No USB Port Error


    Jim,
    I just checked to add ubuntu-mate to the dialout and it tells me that
    ubuntu-mate is already a member of dialout.
    So there is a problem with it finding usb0.
    Could it be that a different radio's cable might be using a serial
    assignment?
    I've used the Tytera cable via USB and Baofeng's cable via USB and it has
    always been recognized.
    Note, the cable I'm stuck with for now is a USB cable that should go with a
    digital radio, the Radioddity GD77-S, so I don't know if it has something
    different to the cable.
    I accidentally sent the Baofeng cable along with the GD77-S that I traded
    for the Kenwood.
    Glenn

    ----- Original Message ----- 
    From: "Jim Unroe" <rock.unroe at gmail.com>
    To: "Discussion of CHIRP" <chirp_users at intrepid.danplanet.com>
    Sent: Friday, May 22, 2020 12:51 PM
    Subject: Re: [chirp_users] No USB Port Error


    On Fri, May 22, 2020 at 1:06 PM Glenn K0LNY <glennervin at cableone.net> wrote:
    >
    > Hi,
    > I just got a new used radio, a Kenwood TH-F6.
    > So I plugged in the radio using a non-Kenwood cable and I went into
    > "radio" and download from radio and selected my radio model and USB0 and I
    > get the message:
    > error no 2 cannot open tty/usb0 error cannot locate tty/USB0.
    > or something similar.
    > I have used this cable and that Ubuntu with Chirp in the past for my other
    > radios, and other than different brands of radios, I have always been able
    > to do this.
    > I know a guy who has done this to this model using the Baofeng cable using
    > a different software in Windows, not the Kenwood software, but one that
    > they purchased.
    > I don't recall the name, but I think it starts with an R.
    > At any rate, I'd sooner buy a Kenwood cable than that other software and
    > keep using Chirp.
    > Hopefully I didn't get it mixed up with the Radioddity cable.
    > I thought I had the right cable with the Radioddity when I sent it off.
    > I don't know if they put the name of the associated radio on the cables,
    > since I'm Blind.
    > But any who, would this be an error for the wrong cable?
    > Thanks.
    > Glenn

    Hi Glenn,

    >From what you are describing it sounds like you Linux user doen't have
    permission to access the port. Either run CHIRP as root or as your
    Linus user to the dialout group.

    I also have a Kenwood TH-F6a. CHIRP programs it in "live" mode.

    Jim KC9HI
    _______________________________________________
    chirp_users mailing list
    chirp_users at intrepid.danplanet.com
    http://intrepid.danplanet.com/mailman/listinfo/chirp_users
    This message was sent to Glenn at glennervin at cableone.net
    To unsubscribe, send an email to
    chirp_users-unsubscribe at intrepid.danplanet.com

    _______________________________________________
    chirp_users mailing list
    chirp_users at intrepid.danplanet.com
    http://intrepid.danplanet.com/mailman/listinfo/chirp_users
    This message was sent to D.J.J. Ring, Jr. at n1ea at arrl.net
    To unsubscribe, send an email to chirp_users-unsubscribe at intrepid.danplanet.com



------------------------------------------------------------------------------


  _______________________________________________
  chirp_users mailing list
  chirp_users at intrepid.danplanet.com
  http://intrepid.danplanet.com/mailman/listinfo/chirp_users
  This message was sent to Glenn at glennervin at cableone.net
  To unsubscribe, send an email to chirp_users-unsubscribe at intrepid.danplanet.com

  _______________________________________________
  chirp_users mailing list
  chirp_users at intrepid.danplanet.com
  http://intrepid.danplanet.com/mailman/listinfo/chirp_users
  This message was sent to D.J.J. Ring, Jr. at n1ea at arrl.net
  To unsubscribe, send an email to chirp_users-unsubscribe at intrepid.danplanet.com


--------------------------------------------------------------------------------


_______________________________________________
chirp_users mailing list
chirp_users at intrepid.danplanet.com
http://intrepid.danplanet.com/mailman/listinfo/chirp_users
This message was sent to Glenn at glennervin at cableone.net
To unsubscribe, send an email to chirp_users-unsubscribe at intrepid.danplanet.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20200603/d11f794e/attachment-0002.html 


More information about the chirp_users mailing list