[chirp_users] Installing Chirp on a 20.04 system.

wa0sbu at kslimmer.com wa0sbu at kslimmer.com
Mon Jul 27 16:57:16 PDT 2020


     I hope this helps, and doesn't confuse too much.  I have tested 
this procedure on several of my systems.  Hopefully I didn't skip something.

You don't need to download Python 2.7 from the Python WEB page, or download
the flatpak.
Its in Focals,(20.04)Repositories.

These are all terminal commands, don't use the quotes.

"sudo apt install python2"  will install 2.7

"ls -ls /usr/bin/python*"  will list your versions of python installed.
In my case 2.7 and 3.8

Add the Chirp repository:

"sudo apt-add-repository ppa:dansmith/chirp-snapshots"

Update:

"sudo apt update"

Next Step from The Chirp WEB page:

"sudo apt-get install chirp-daily"

Returns an error.

"E: Unable to locate package chirp-daily"

In terminal, open your file manager as sudo.
I use Xubuntu, so I use "Sudo thunar" Your command will
match your desktop.

Using mousepad, or text editor,
Edit, "/etc/apt/sources.list.d/dansmith-ubuntu-chirp-snapshots-focal.list"

Change: "deb http://ppa.launchpad.net/dansmith/chirp-snapshots/ubuntu 
focal main"
to: "deb http://ppa.launchpad.net/dansmith/chirp-snapshots/ubuntu bionic 
main"

"sudo apt update"
"sudo apt-get install chirp-daily"

Another error:
"The following packages have unmet dependencies" And a list of 4 of them.

Download the first missing file:

"https://packages.ubuntu.com/bionic/amd64/python-libxslt1/download"

Save it, don't open it.

"cd Downloads"

"sudo dpkg -i python-libxslt1_1.1.29-5ubuntu0.2_amd64.deb"
Another error:
"sudo apt install -f"
"sudo apt-get install chirp-daily"

Now we are down to 3 missing dependencies.

Download from here:

"https://packages.ubuntu.com/bionic/amd64/python-gtk2/download"

"sudo dpkg -i python-gtk2_2.24.0-5.1ubuntu2_amd64.deb"
"sudo apt install -f"
"sudo apt-get install chirp-daily"

Down to 2 missing, getting closer.


Download the next one from here"

"https://packages.ubuntu.com/bionic/all/python-serial/download"
"sudo dpkg -i python-serial_3.4-2_all.deb"


  There, now we are down to 1 missing:

"https://packages.ubuntu.com/bionic/all/python-suds/download"
  "sudo dpkg -i python-suds_0.7~git20150727.94664dd-5_all.deb"

Another error:

"sudo apt install -f"

"sudo apt-get install chirp-daily"

It installed,  chirpw returns an error;
  "python-future" is missing.

"https://packages.ubuntu.com/bionic/all/python-future/download"

"sudo dpkg -i python-future_0.15.2-4ubuntu2_all.deb"


Another dependency error:

"sudo apt install -f"

"chirpw"  its running.





More information about the chirp_users mailing list