[chirp_users] Compiling chirp on Linux mint 20 and failed chirp build in the ppa

Tony Fuller goldstar611 at hotmail.com
Tue Jul 21 11:30:40 PDT 2020


Hi,

It looks like you are mixing some python2 and python3 commands. When you use the 'pip3' command it installs packages for python3. This also applied when using 'apt install python3-*' Hopefully it is clear (on the website) that Chirp is python2 only at the moment.

It appears that Linux Mint 20 is based on Ubuntu 20.04 which has dropped many packages that utilize python2. This creates a scenario where you can't *easily* get the packages needed to run Chirp (at least not with apt or pip).

There are several ways to move forward:
1. A chirp user here mentioned another ham packaged up the necessary .Deb files for chirp to run. Search the chirp-users archive for that link. I don't have it handy.
2. Install flatpak to your system and install the chirp.flatpak installer from the command line.
The .flatpak installer is published next to the windows and Mac installers at https://trac.chirp.danplanet.com/chirp_daily/LATEST/
See comment #4 for some additional flatpak instructions at https://chirp.danplanet.com/issues/7837

Tony
________________________________
From: chirp_users-bounces at intrepid.danplanet.com <chirp_users-bounces at intrepid.danplanet.com> on behalf of Haken Hveem <krbjhvee at online.no>
Sent: Tuesday, July 21, 2020 1:10:25 PM
To: Discussion of CHIRP <chirp_users at intrepid.danplanet.com>
Subject: [chirp_users] Compiling chirp on Linux mint 20 and failed chirp build in the ppa


Hello, I have tried :
apt-get install python-gtk python-serial python-libxml2

Those are not present in the repositories for Linux mint 20.


I tried to install:

python-libxml2

python-wxgtk-media3.0

python-wxgtk-webview3.0

python3-serial

+ other packages mentioning python and serial + gtk.


No luck on that.

Installed python3-pip and did :
./chirpw
WARNING: python-future package is not available; chirp.drivers.anytone778uv requires it
WARNING: python-future package is not available; chirp.drivers.ga510 requires it
Traceback (most recent call last):
  File "./chirpw", line 24, in <module>
    from chirp.drivers import *
  File "/home/haaken/Nedlastinger/chirp-daily-20200718/chirp/drivers/idrp.py", line 16, in <module>
    import serial
ImportError: No module named serial

Then tried :

 pip3 install serial
Collecting serial
  Downloading serial-0.0.97-py2.py3-none-any.whl (40 kB)
     |████████████████████████████████| 40 kB 602 kB/s
Requirement already satisfied: iso8601>=0.1.12 in /usr/lib/python3/dist-packages (from serial) (0.1.12)
Requirement already satisfied: pyyaml>=3.13 in /usr/lib/python3/dist-packages (from serial) (5.3.1)
Requirement already satisfied: future>=0.17.1 in /usr/lib/python3/dist-packages (from serial) (0.18.2)
Installing collected packages: serial
Successfully installed serial-0.0.97

Still the same issue with
./chirpw

How do I solve this, and WHY is there no packet available in the dansmith ppa ?

There is apparently a depency missing to build the package for Focal, because according to the build log:

Build status

[MANUALDEPWAIT] Dependency wait on lgw01-amd64-022

    Missing build dependencies: python-serial
    Started on 2020-07-18
    Finished on 2020-07-18 (took 1 minute, 37.3 seconds)


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20200721/b9f14931/attachment-0002.html 


More information about the chirp_users mailing list