[chirp_users] Error using CHIRP with my AnyTone AT778-UV

Tony Moriarty boris.bandit at gmail.com
Sun Jul 19 01:38:05 PDT 2020


Hi.

Firstly, although I've used Chirp for years, this is the first time I've
used this forum - please be patient with me!

I was delighted to discover recently that Chirp now supports the Anytone
778-UV - I've had one for a while, and the "other" software available for
it was rather limited.

Anyway, having downloaded the latest daily build and attempted to read the
radio, I'm getting an error message that includes the text :

"Radio version not in allowed list for AnyTone-778UV: 000: 49 41 54 37 37
38 55 56   IAT778UV

008: 01 56 31 30 30 00 00 06   .V100..."

It appears that Chirp is correctly interacting with the radio via the
relevant com port, but doesn't like what the radio tells it.

Since there doesn't seem to have been a rash of issues raised on this
subject, I didn't want to raise it as a bug report till I'd made enquiries
here.

My PC runs an up-to-date installation of Windows 10

The debug file includes the following (I've chopped out lines that don't
seem relevant!):

[2020-07-19 08:50:02,053] chirp.logger - DEBUG: CHIRP daily-20200718 on
WinVista/7 (Python 2.7.10)

.

.

.

[2020-07-19 08:50:02,224] chirp.directory - INFO: Registered AnyTone_778UV
= AnyTone778UV

[2020-07-19 08:50:02,224] chirp.directory - INFO: Registered Retevis_RT95 =
RetevisRT95

[2020-07-19 08:50:02,224] chirp.directory - INFO: Registered CRT_Micron_UV
= CRTMicronUV


[2020-07-19 08:50:02,397] chirp.directory - INFO: Registered
Vertex_Standard_VXA-700 = VXA700Radio

[2020-07-19 08:50:02,397] elib.intl - DEBUG: Set environment variable
'LANG' to 'en_GB' ('kernel32.SetEnvironmentVariableW')

[2020-07-19 08:50:02,397] elib.intl - DEBUG: Set environment variable
'LANG' to 'en_GB' ('msvcrt._putenv')

[2020-07-19 08:50:02,397] elib.intl - DEBUG: Set environment variable
'LANG' to 'en_GB' ('msvcr90._putenv')

[2020-07-19 08:50:02,928] chirp.ui.mainapp - INFO: Skipping existing stock
config

[2020-07-19 08:50:02,928] chirp.ui.mainapp - INFO: Skipping existing stock
config

[2020-07-19 08:50:02,928] chirp.ui.mainapp - INFO: Skipping existing stock
config

[2020-07-19 08:50:02,928] chirp.ui.mainapp - INFO: Skipping existing stock
config

[2020-07-19 08:50:02,928] chirp.ui.mainapp - INFO: Skipping existing stock
config

[2020-07-19 08:50:02,928] chirp.ui.mainapp - INFO: Skipping existing stock
config

[2020-07-19 08:50:02,928] chirp.ui.mainapp - INFO: Skipping existing stock
config

[2020-07-19 08:50:02,928] chirp.ui.mainapp - INFO: Skipping existing stock
config

[2020-07-19 08:50:02,928] chirp.ui.mainapp - INFO: Skipping existing stock
config

[2020-07-19 08:50:02,928] chirp.ui.mainapp - INFO: Skipping existing stock
config

[2020-07-19 08:50:02,928] chirp.ui.mainapp - INFO: Skipping existing stock
config

[2020-07-19 08:50:02,928] chirp.ui.mainapp - INFO: Skipping existing stock
config

[2020-07-19 08:50:02,928] chirp.ui.mainapp - INFO: Skipping existing stock
config

[2020-07-19 08:50:02,928] chirp.ui.reporting - DEBUG: Checking for updates

[2020-07-19 08:50:03,351] chirp.ui.reporting - DEBUG: Server reports
version daily-20200718 is latest

[2020-07-19 08:50:14,335] chirp.ui.mainapp - DEBUG: User selected AnyTone
778UV on port COM3

[2020-07-19 08:50:14,430] chirp.ui.clone - DEBUG: Clone thread started

[2020-07-19 08:50:14,944] chirp.drivers.anytone778uv - DEBUG: entered
program mode

[2020-07-19 08:50:15,444] chirp.drivers.anytone778uv - DEBUG: ver_response
=

[2020-07-19 08:50:15,444] chirp.drivers.anytone778uv - DEBUG: 000: 49 41 54
37 37 38 55 56   IAT778UV

008: 01 56 31 30 30 00 00 06   .V100...


[2020-07-19 08:50:15,444] chirp.drivers.anytone778uv - DEBUG: radio model:
'AT778UV' version: 'V100'

[2020-07-19 08:50:15,444] chirp.drivers.anytone778uv - DEBUG: allowed_types
= {'AT778UV': ['V200']}

[2020-07-19 08:50:15,444] chirp.drivers.anytone778uv - DEBUG: model in
allowed_types

[2020-07-19 08:50:15,944] chirp.ui.reporting - DEBUG: Reporting exception

[2020-07-19 08:50:15,944] chirp.ui.common - ERROR: -- Exception: --

[2020-07-19 08:50:15,944] chirp.ui.common - ERROR: Traceback (most recent
call last):

  File "chirp\ui\clone.pyo", line 256, in run

  File "chirp\drivers\anytone778uv.pyo", line 569, in sync_in

  File "chirp\drivers\anytone778uv.pyo", line 371, in do_download

RadioError: Radio version not in allowed list for AnyTone-778UV: 000: 49 41
54 37 37 38 55 56   IAT778UV

008: 01 56 31 30 30 00 00 06   .V100...



[2020-07-19 08:50:15,944] chirp.ui.common - ERROR: ----------------

[2020-07-19 08:50:15,944] chirp.ui.clone - ERROR: Clone failed: Radio
version not in allowed list for AnyTone-778UV: 000: 49 41 54 37 37 38 55 56
  IAT778UV

008: 01 56 31 30 30 00 00 06   .V100...


[2020-07-19 08:50:16,007] chirp.ui.clone - DEBUG: Clone thread ended

[2020-07-19 08:50:16,007] chirp.ui.reporting - DEBUG: Reporting model
usage: AnyTone_778UV,download,True

[2020-07-19 08:50:16,007] chirp.ui.reporting - DEBUG: Reporting exception

[2020-07-19 08:50:16,007] chirp.ui.inputdialog - ERROR: --- Exception
Dialog: Radio version not in allowed list for AnyTone-778UV: 000: 49 41 54
37 37 38 55 56   IAT778UV

008: 01 56 31 30 30 00 00 06   .V100...

 ---

[2020-07-19 08:50:16,007] chirp.ui.inputdialog - ERROR: Traceback (most
recent call last):

  File "chirpw", line 68, in <module>

AttributeError: 'NoneType' object has no attribute 'split'


[2020-07-19 08:50:16,007] chirp.ui.inputdialog - ERROR:
----------------------------



I'm happy to provide more info if needed.

Can anyone suggest a way forward, please?

All the best,

Tony Moriarty
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20200719/4755247d/attachment-0002.html 


More information about the chirp_users mailing list