[chirp_users] Mac IC80AD RTSytems Cable

Chip Griffin n1mie at mac.com
Tue Jun 11 16:24:01 PDT 2019


I’m getting an "AttributeError: 'Serial' object has no attribute ‘get_payload’” error when I try to read from my Icom IC-80AD. It’s instantaneous to when I start. I’ve looked at drivers and can’t find the alleged Apple FTDI driver. When I look in the directory IOUSBFamily.ktext I only see the following options:

AppleLegacyUSBAudio.kext/    IOUSBCompositeDriver.kext/   IOUSBHIDDriverSafeBoot.kext/ 
AppleUSBLegacyHub.kext/      IOUSBHIDDriver.kext/         IOUSBLib.bundle/             
AppleUSBMergeNub.kext/       IOUSBHIDDriverPM.kext/       IOUSBUserClient.kext/

When I do a $ ls /dev/cu* I see:
/dev/cu.Bluetooth-Incoming-Port	/dev/cu.usbserial-RT3P07W9

I’ve tried both. Bluetooth doesn’t even come close to happiness and the RT3P07W9 one gives me the above error.

I do have the KK7DS stuff installed, even tried installing it a second time to be sure. 


I also tried on my Vista machine with even more pathetic results.


--
    Chip




More information about the chirp_users mailing list