[chirp_users] CHIRP and Mac High Sierra

Dave B g8kbv at uku.co.uk
Mon Jan 1 12:54:52 PST 2018


Hi again.

Other thought.   Are you running as a user with "permissions" to use
Serial ports?   In some of the Linux world, that'd be, as a member of
the "Dialout" group.  (I have no idea if Mac OS, though based on BSD
uses the same scheme.)

Do you have other USB/serial port adapter using equipment/gadgets that
do work OK, if so you could look into and find out how that references
attached USB<>RS232 devices.

Also, after some googling (Always your first port of call) I see others
with similar problems, who found that using an external USB hub device
(connected via the Thunderbolt main port) allowed all sorts of "other"
vendor kit to work, that just would not when connected directly to the
Mac.  (Mac Mini's in those cases I think.)   Maybe the Serial adapters
are asking for too much power?  Unlikely, but?

Lastly, you say you "Ran all the terminal codes." but you don't actually
list exactly what you tried, and what the results were.

I don't know how exactly, but I suspect that even Mac's have a command
line option, or even a GUI tool, to examine what hardware you have
connected to what port and tell you how it would appear to an
application, or tell you why it can't be used.

I see many Mac users attempting to use them for Ham Radio work.  Unless
they are using pre-made commercial applications designed and built for
Mac's, they usually have lots of trouble.  (There are exceptions.)

You need to list the exact computer model, specification and version you
have, the exact OS version you're running, plus any error or alert
messages you get, from commands you try.   Then, someone else here who's
also a Mac user will probably be able to guide you through the maze and
hopefully get it sorted.

73.

Dave G0WBX.



On 01/01/18 20:00, chirp_users-request at intrepid.danplanet.com wrote:
> From: Parrish Roberson <psound18 at yahoo.com>
> Subject: Re: [chirp_users] chirp_users Digest, Vol 108, Issue 19
> To: Discussion of CHIRP <chirp_users at intrepid.danplanet.com>
> Message-ID: <EEEF6D1B-57BA-4C77-8F65-7333B85FBC63 at yahoo.com>
> Content-Type: text/plain; charset="utf-8"
>
> Ran all the terminal codes. Doesn?t see the port or cable on the Mac or on parallels tried 2 different BaoFeng cables. Odd they would both be bad. Hopefully it will work soon. Thanks

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20180101/2607d0cf/attachment-0002.html 


More information about the chirp_users mailing list