[chirp_users] TS-2000 CVS imports fail...

Allan allanhasmail at gmail.com
Tue Jul 4 07:02:33 PDT 2017


What am I doing wrong to program 100 Kenwood TS-2000 memories the easy 
way with Chirp???

I installed CHIRP daily-20170627 on Mint 18.2, downloaded my radio, 
wrote out a CSV file, constructed what I want, saved that CSV, and when 
I try to import it, via:

start Chirp, start radio, DL radio: I see the existing memories fine.

I import my CSV file: "There was an error during import: `?' is not in 
valid list: t: ['WFM', 'FM', 'NFM', 'AM', 'NAM', 'DV', 'USB', 'LSB', 
'CW', 'RTTY', 'DIG', 'PKT', 'NCW', 'NCWR', 'CWR', 'P25', 'Auto', 
'RTTYR', 'FSK', 'FSKR', 'DMR']

I click OK and Chirp appears to hang with the message: "Preparing memory 
list..." (I kill it after 10 minutes).

I've looked at my CSV file: there is no '?' character in the file. I see 
nothing wrong (I fixed default values for rToneFreq and cToneFreq).

Here's a shorter CSV I tried, same results:

Location,Name,Frequency,Duplex,Offset,Tone,rToneFreq,cToneFreq,DtcsCode,DtcsPolarity,Mode,TStep,Skip,Comment,URCALL,RPT1CALL,RPT2CALL
100,CREDIT ,29.62,-,0.1,,88.5,88.5,23,NN,FM,5,,,,,
101,BLOOMIN,29.66,-,0.1,Tone,100,88.5,23,NN,FM,5,,,,,
102,CHASKA,53.03,-,0.1,,88.5,88.5,23,NN,FM,5,,,,,
103,FALCON ,53.15,-,0.1,,88.5,88.5,23,NN,FM,5,,,,,
104,CREDIT ,53.33,-,0.1,,88.5,88.5,23,NN,FM,5,,,,,

If even fails if I try to import the exported file previous read.

Poking around in the log file I see:

>
> [2017-07-04 07:49:24,222] chirp.drivers.kenwood_live - DEBUG: 
> PC->RADIO: MR0007;
> [2017-07-04 07:49:24,374] chirp.drivers.kenwood_live - DEBUG: 
> RADIO->PC: MR000700000000000000000000000000000000000;
> [2017-07-04 07:49:24,375] chirp.ui.common - ERROR: Exception running 
> RadioJob: `?' is not in valid list: ['WFM', 'FM', 'NFM', 'AM', 'NAM', 
> 'DV', 'USB', 'LSB', 'CW', 'RTTY', 'DIG', 'PKT', 'NCW', 'NCWR', 'CWR', 
> 'P25', 'Auto', 'RTTYR', 'FSK', 'FSKR', 'DMR']
> [2017-07-04 07:49:24,375] chirp.ui.reporting - DEBUG: Throttling...
> [2017-07-04 07:49:24,375] chirp.ui.common - ERROR: -- Exception: --
> [2017-07-04 07:49:24,375] chirp.ui.common - ERROR: Traceback (most 
> recent call last):
>   File "/usr/lib/python2.7/dist-packages/chirp/ui/common.py", line 
> 116, in _execute
>     result = func(*self.args, **self.kwargs)
>   File "/usr/lib/python2.7/dist-packages/chirp/drivers/ts2000.py", 
> line 111, in get_memory
>     mem = self._parse_mem_spec(result)
>   File "/usr/lib/python2.7/dist-packages/chirp/drivers/ts2000.py", 
> line 147, in _parse_mem_spec
>     mem.mode = TS2000_MODES[int(_p5)]
>   File "/usr/lib/python2.7/dist-packages/chirp/chirp_common.py", line 
> 336, in __setattr__
>     (val, self._valid_map[name]))
> ValueError: `?' is not in valid list: ['WFM', 'FM', 'NFM', 'AM', 
> 'NAM', 'DV', 'USB', 'LSB', 'CW', 'RTTY', 'DIG', 'PKT', 'NCW', 'NCWR', 
> 'CWR', 'P25', 'Auto', 'RTTYR', 'FSK', 'FSKR', 'DMR']

It seems to not like all zeros in memorys set by a factory reset... but 
it seems to only cause problems when it occurs during an import, not 
editing from the memory value fields.

Allan




More information about the chirp_users mailing list