[chirp_users] Trying to program a Yaesu FT60R with Mac OS 10.12.2

Jim Unroe rock.unroe at gmail.com
Sun Jan 29 16:19:09 PST 2017


Hi Rick,

First I want to make it clear that I am not a Mac user. What I write
below is based on many years of monitoring this mailing list and
experience with several programming cables.

Many programming cables have unauthorized copies of Prolific
USB-to-TTL UART chips in them. This is especially true if the listing
doesn't say which UART is used.

The drivers that are supplied by Prolific, since around 2008, for
Windows and Mac have been designed to be incompatible with
unauthorized (aka counterfeit) Prolific type UART chips.

On Sun, Jan 29, 2017 at 6:04 PM, Rick Rottman <rottman.rick at gmail.com> wrote:
> Hi,
>
> I am new to this and trying to program my Yaesu FT60R.
> I have an iMac running OS 10.12.2 (Sierra).
> I purchased a 6 in 1 programming cable for the FT60R (among many other models) from Yihao Weiye Electronics Co. LTD, via Amazon.

All 6 in 1 programming cables that I have ever purchased have
contained counterfeit Prolific chips, as does yours.

> I have installed KK7DS Python Runtime R10 on my Mac.
> I have tried downloading a few FTDI drivers.

FTDI drivers are of no use to you since your programming cable does
not contain an FTDI chip. If it did, since El Capitan, it is
recommended that the native Apple FTDI driver is used. Once again,
this does not help you since your programming cable does not have an
FTDI chip.

> I can install and open Chirp-daily 2016-12-20, but not chirp-daily-20170126.

I can't help you with this but I can assure you that many Mac users
are successfully using the latest version of CHIRP.

> When I connect the programming cable to my powered USB hub, System Information recognizes it as:
>         USB Serial Controller
>         product ID: 0x2303
>         vendor ID: 0x067b (Prolific Tech. Inc)
>         version 3.00
>         plus other info…

Proof that your programming cable contains a Prolific type UART chip
with a greater than 99% chance of it being an unauthorized copy.

>
> I connect radio to computer via cable, power up radio into clone mode, select “download from radio” (both with and without opening new file),
> then select Yaesu and FT60 from the popup menu, which lists the port as: /dev/cu.SLAB_USBtoUART.
> I push the PTT key for a second until my radio shows “tx” then release.
> After a few seconds chirp gives me the message: “An error has occurred, Failed to communicate with radio: Radio is not responding.
>
> I've tried this multiple times. Any suggestions or assistance would be much appreciated!
> Thanks
>  Rick Rottman

The workaround for Windows user is to download install and select a
Prolific device driver that was available before Prolfic decided to
make it incompatible with counterfeit chips. Mac OS X users prior to
El Capitan were able to install a generic Prolific driver. But OS X
security enhancements make this harder to do.

I have now seen several Mac OS X users claim the solution for them was
to purchase this 3rd party driver.

https://www.mac-usb-serial.com/

Another would be to replace the USB end with a module containing a
different UART chip. The CP2102 is popular and this page shows you
how.

http://www.miklor.com/COM/UV_ProgrCable.php

A 3rd solution would be to get a programming cable with an FTDI chip
and use the native Apple driver.

Good luck...

Jim KC9HI



More information about the chirp_users mailing list