[chirp_users] Error trying to access radioreference.com

John Schubert chirp at n6jes.us
Sat Oct 1 13:52:48 PDT 2016


On Wed, 28 Sep 2016 19:17:12 -0700, I wrote:
> Hi,
> I have recently updated to El Capitan and am no having problems trying to access
> radioreference.com from Chirp. I reinstalled KK7DS Python runtime for Mac OSX
> and then updated CHIRP to daily-20160926. The error I get is:
>
> "Suds library required for RadioReference.com import.
> Try installing your distribution's python-suds package."



I solved the problem...  The list suggestions & web info didn't work, but helped
with clues and likely distracted me to use my python.

I ended up changing chirp to use my MacPorts python. I did a clean install on a
different [Mavericks] system to eliminate any potential left over collateral. I
then applied the same changes to my El Capitan MacBook to verify...

For those the feel adventurous:
1) edit chirp (/Applications/Chirp.app/Contents/MacOS/chirp):
   ##
PYTHON=/opt/kk7ds//Library/Frameworks/Python.framework/Versions/2.7/Resources/Python.app/Contents/MacOS/Python

PYTHON=/opt/local/Library/Frameworks/Python.framework/Versions/2.7/Resources/Python.app/Contents/MacOS/Python

   you may need to adjust the path to match your python & chirp installation.

2) If chirp was previously installed, otherwise skip:
   a) rename or delete /opt/kk7ds
   b) delete soft link /Applications/Chirp.app/Contents/MacOS/../CHIRP
3) install any missing python modules (example for MacPorts):
   sudo port install py-serial py27-pygtk py-suds

Run will open X Windows (XQuartz)...

73
John



More information about the chirp_users mailing list