[chirp_users] IC-T70A not communicating with Chirp

Nicholas Papadonis npapadonis at yahoo.com
Tue May 26 15:09:31 PDT 2015


Folks,

I’m having a similar issue as below and filed the following bug:

http://chirp.danplanet.com/issues/2605

I have tested both Genuine FTDI and Prolific USB->Serial cables with no success. The USB->Serial chips are detected by both Windows 7 and Mac OS, however when Chirp sends out the 0xE0 detection frame, there is always a 0 byte response back when I would have suspected at least a byte for the Model ID according to the code. I have tested Chirp all the way back to v1.1 when the code log says T70A support was first added. My assumption is that it must have worked back then, however this is not confirmed yet. It’s odd that both cables resulted in 0 byte reads and now I’m suspecting either the T70A has a different protocol or newer manufactured firmware that changed the control codes.

Has anyone validated the IC-T70A *ever* worked with Chirp? If so, can you share your experience and possibly the serial number and purchase date of the radio?

Thanks,
Nick
KB1GZN

> Thank you very much David, After trying many other things... I ran the cable loop back tester software, and set to COM3. Ran the test and nothing happens. I have tried this with the radio just turned on. I have tried this with hreadio in the CLONE mode. I have tried this with the radio in the CLONE OUT mode. I never get any response. I think perhaps I have a bad cable - sigh! One other clue is that the cable makes the radio SCAN whenevr I plug it in normally I have to fiddle with it and reinsert it numerous times before it will stop scanning and sit at a fixed frequency. The supplier assures me these are not the fake chips but genuine FTDI chips he is using, and charged a premium price for it. The cable came from Mark Dunkle, KJ6ZWL. I will relay all of this information and see if he can send me another cable that works. Manufacturer: FTDI on USB Serial Converter Driver Provided: FTDI 8/26/2014 Driver Version: 2.12.0.0 Brian Carling



More information about the chirp_users mailing list