[chirp_users] IC-T70A: has anyone programmed it successfully?

Nicholas Papadonis npapadonis at yahoo.com
Thu May 21 16:07:08 PDT 2015

Hi Folks,

   Has anyone heard reports of an Icom IC-T70A or IC-T70E working with Chirp?  I'm having difficulty programming this radio, however can program my Baofeng.

   I have a Genuine FTDI USB cable.  Unfortunately, I keep getting an error downloading from the radio.  "Failed to communicate with the radio: Unexpected response from radio".  As device manager says the COM port is ok, I'm suspecting something else is going on.   The USB serial cable is properly detected by my Mac OSX v10.10.3 as a USB serial device. The device properly appears in the OS as /dev/cu.usbserial-A9030T4G. I tried a couple versions of Chirp and used this device path. In my tests I tried downloading from the radio both by specifying Icom / IC-T70 and then Icom / Autodetect. Both setting resulted in failure to communicate with the radio. The radio then begins to cycle memory channels after the download fails.  I have attached the Chirp debug log from a recent daily build 2015-05-02.  I tried an older build from a year ago from 2014-12-15 with the same results.  I have also noticed a few bugs around this radio and wondering if perhaps an older Chirp build works correctly.

   Any insight is appreciated.

New York, NY USA
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20150521/d6691c99/attachment-0004.html 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: debug.log
Type: application/octet-stream
Size: 14117 bytes
Desc: not available
Url : http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20150521/d6691c99/attachment-0002.obj 
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20150521/d6691c99/attachment-0005.html 

More information about the chirp_users mailing list