[chirp_users] FT-2900r won't upload

Rich Cochran/AG6QR
Thu Dec 10 13:14:43 PST 2015

I wrote most of the FT-2900 driver, and I'll maintain it as needed.  It
has been pretty stable for quite some time now, and I've had good 
from people who have used it, so I'm confident it's basically working,
but there's probably room for improvement.

Thanks, David, for the suggestion about the lock button.  I haven't
tried that, and I'm away from my radio right now, but there may be
something I can do to the driver to make it at least give a better
error message when that situation is encountered.

Al: If you can download from the radio, then your cable is almost
certainly working.  Downloading requires communications in both
directions.  There's a remote chance that the cable length,
impedance, or some other analog characteristic is such that it's
producing intermittent problems, but I doubt it.

If it's not the lock issue which David suggested, then contact
me off list, and send me the file you're trying to upload.  I'll
take a look and see what I can discover.

--Rich, AG6QR
ag6qr at sonic.net

> Al, I don't know if this is your problem or not but it is something to
> check.  The last time I tried to program my 2900 the radio wouldn't 
> accept
> the upload.  Then I realized that I had the lock turned on when I had 
> used
> it the time before.  As soon as I unlocked all was good.  I haven't had 
> the
> 2900 long and it took be a couple of minutes to notice the lock icon.
> Thanks,
> David, kd7uch at arrl.net
> On Dec 9, 2015 5:07 PM, "Al Cohan" <alcohan at mailserversusa.com> wrote:
>> Hello, I just joined this list and I am pulling out my hair trying to
>> figure out why CHiRP won't upload to my new Yaesu FT-2900r.
>> I am on my third cable. It is a Valley Enterprises FTDI cable using 
>> the
>> proper driver software. I can download after following the procedure 
>> to
>> hold the A/N Low button in while powering on the radio then reading 
>> from
>> radio.
>> I have great success with using CHiRP with all my other radios, but 
>> the
>> FT-2900r cannot be written to.
>> Please, any thoughts. I tried looking at a CHiRP forum, but something
>> was wrong with my account.

More information about the chirp_users mailing list