[chirp_users] Trying to use chirp via ser2net and socat

Tom Hayward tom at tomh.us
Wed Nov 5 13:50:46 PST 2014


On Wed, Nov 5, 2014 at 1:23 PM, Nigel Johnson, MIEEE
<nw.johnson at ieee.org> wrote:
> Hi, I wonder if anybody has tried this and can offer advice: I have chirp running on a laptop in my apt, but an FT8900 is in a boiler room one the roof.  The remote control head for the radio is down in the apartment.
>
> I can connect to the FT8900 by running a ser2net service up there and socat down here.  With this setup and permissions all set OK using /dev/pts/5, I can see the FT8900 send a character when I put it into clone mode.  But chirp will not recognise anything and gives me "Failed to communicate with radio: Failed to read header (0)"
>
> I am using SuSE linux here and CentOS upstairs.  I have tried setting the serial port up there to 1200, 4800, 9600 and 19200.  I assume that chirp uses autobauding to communicate with the radio but that is obviously not available over a tcp connection.
>
> Any help would be appreciated!
>
> 73 de Nigel ve3id

The FT-8900 uses 9600 serial, but it can't actually receive data that
fast. It's picky about timing. Chirp sends it 64 bytes of data, waits
for an ACK, then waits another 50 ms for the radio to finish before
sending the next block. Your network link may be messing up this
timing.

First step is to try again at 9600.

Tom KD7LXL



More information about the chirp_users mailing list