[chirp_users] Trying to use chirp via ser2net and socat

Nigel Johnson
Thu Nov 6 05:34:30 PST 2014

Hmm, interesting.  I didn't realise it was half duplex.  I have tried
telnetting to the port and the only echo I get is the carriage return,
then nothing.  Time to get the scope out :-)

73 NIgel ve3id


Nigel Johnson

Amateur Radio, the origin of the open-source concept!


You can reach me by voice on Skype:  TILBURY2591

If time travel ever will be possible, it already is. Ask me again yesterday

This e-mail is not and cannot, by its nature, be confidential. En route from me to you, it will pass across the public Internet, easily readable by any number of system administrators along the way.
   Nigel Johnson <nw.johnson at ieee.org>

Please consider the environment when deciding if you really need to print this message

On 11/05/2014 04:37 PM, Andrew wrote:
> On 05/11/14 21:23, Nigel Johnson, MIEEE wrote:
>> I am using SuSE linux here and CentOS upstairs.  I have tried setting the serial port up there to 1200, 4800, 9600 and 19200.  I assume that chirp uses autobauding to communicate with the radio but that is obviously not available over a tcp connection.
> I had a quick look in the source code and it appears to use 9600:
> class FTx800Radio(yaesu_clone.YaesuCloneModeRadio):
>      """Base class for FT-7800,7900,8800,8900 radios"""
>      BAUD_RATE = 9600
> What you could do is to unplug the cable from the radio and connect the 
> TX and RX pins together. (I don't know what the cable is so I don't know 
> which pins this or how easy it would be to do.)
> Once you do that any data you manage to send to the serial port will 
> come straight back again, so you can test that the link is working, and 
> it works at any baud rate.

More information about the chirp_users mailing list