[chirp_users] [vx-3] - daily build with vx3 fix will not upload to radio

Jens J. kd4tjx at yahoo.com
Sun Feb 23 20:27:47 PST 2014

(I meant the bank issue, sorry)

 From: Jens J. <kd4tjx at yahoo.com>
To: Discussion of CHIRP <chirp_users at intrepid.danplanet.com> 
Sent: Sunday, February 23, 2014 10:21 PM
Subject: Re: [chirp_users] [vx-3] - daily build with vx3 fix will not upload	to	radio

Hi Bob,

For this issue, please document it in a bug.

refer to:


 From: bob <n612dw at gmail.com>
To: chirp_users at intrepid.danplanet.com 
Sent: Sunday, February 23, 2014 9:43 PM
Subject: [chirp_users] [vx-3] - daily build with vx3 fix will not upload to	radio

Hi Jens,
Tnx for the comments/effort.
Basically, to some extent using Chirp seems somewhat untenable unless BOTH problems are resolved.  At least for the vx-3.
In one case, one cannot add/modify/import any new/blank memories, and in the other one cant upload. 
Python is all new to me, but I did take the time to install the development environment (and a code image from d-rats.com) and got Chirp to work against all the .py sources so I don’t have to wait for a build to try stuff (that’s how I poked your vx3.py fix in and noticed it worked).  Don’t know how to get a useful debugger working/up in this environment, but that’s gravy.  I noticed that there is a way to install python into my Visual Studio environment but that is more than I can chew today.   
I have tried a copy/paste operation you mention on multiple channels with the last build, and that seems to work to force feed  or “seed” new memory slots to get them initially populated.   This seems to be the ONLY way I can modify/edit/create a blank/new memory slot given the other bug.   Assuming then once the memory slot is populated, then I can successfully import to them (importing to existing does work).   This may be a workaround one can live with for the time being… good idea. 
I will take my original uploaded radio image and copy/paste the 11 already used memories into the first 2-300 memory slots (as many as I need) to “seed” them, and then import over the top of them.  Lets see if that works. 
In the second, any inability to upload successfully mitigates any reason to use Chirp.   I can certainly wait a few days for the upload fix as this is beyond me to attempt to fix.   I will build a .img that does the above and then await the upload fix…
I also noticed another problem when working on the latest build related to assigning memories to banks.
Lets say that we have 100 memories for 2 meters, and another 100 memory slots for 440.
When you use the “bank Editor”…  as I selected the first 100 memories to be tagged with Bank 1, when I started selecting the second 100 for 440 on the second bank, about halfway through I got an error dialog box that indicated that I hit a limit on how many memories were selected for Bank 1, yet I was selecting bank 2’s memory slots at the time.  Since this takes a bit of hassle to set back up (I hit the error on the 257’t change, according to the dialog box) to test, I’ll need to time to reproduce again.
It may be just that there is a limit on how many memory slots can be assigned at once in a single “changeset”? Or banks not counted uniquely?… no idea.   If I get a chance to grab a debug.log file on this too I will, not sure I recall exactly what happened.   Shortly after this I ran into the “can’t upload” problem and I got frustrated at that point (as it wiped out the radio on the error) and called it a day.
chirp_users mailing list
chirp_users at intrepid.danplanet.com

chirp_users mailing list
chirp_users at intrepid.danplanet.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20140223/8e2c6e66/attachment-0005.html 

More information about the chirp_users mailing list