[chirp_users] Kenwood TM-281 Error

Phillip Anderson pcanderson at gmail.com
Mon Feb 17 00:42:02 PST 2014


I'm running the daily build from 2014/02/16 and trying to connect my
Kenwood TM-281 on Arch Linux. The radio is listed as supported on the Chirp
homepage ("TM-271A/281A"), but when I try to connect I get the following
errors:


When trying to autodetect a Kenwood from the USB port:

Trying ID at baud 9600
PC->RADIO: ID
Timeout waiting for data
D7->PC: ID TM-281
--- Exception Dialog: Unsupported model `TM-281' ---
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/chirpui/clone.py", line 170, in run
    cs.radio_class = detect.DETECT_FUNCTIONS[vendor](cs.port)
  File "/usr/lib/python2.7/site-packages/chirp/detect.py", line 100, in
detect_kenwoodlive_radio
    raise errors.RadioError("Unsupported model `%s'" % r_id)
RadioError: Unsupported model `TM-281'


When telling Chirp that it's a TM-271 (since they're lumped on the
homepage):

User selected Kenwood TM-271 on port /dev/ttyUSB0
Trying ID at baud 9600
PC->RADIO: ID
D7->PC: ID TM-281
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/chirpui/mainapp.py", line 1357, in
mh
    self.do_download(*args)
  File "/usr/lib/python2.7/site-packages/chirpui/mainapp.py", line 637, in
do_download
    radio = settings.radio_class(ser)
  File "/usr/lib/python2.7/site-packages/chirp/kenwood_live.py", line 126,
in __init__
    self.MODEL))
Exception: Radio reports TM-281 (not TM-271)


Is there a way to get this radio working with Chirp? Somebody must have
thought it worked at some point since it's on the homepage.

Phil
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20140217/ca9919c3/attachment-0002.html 


More information about the chirp_users mailing list