[chirp_users] chirp.config file on Mac with chirp 0.3.0

chirp.cordless at xoxy.net chirp.cordless at xoxy.net
Thu Mar 7 20:47:11 PST 2013


I've updated to 0.3.0; from the file date on my Mac, on Feb 15.
Previously I was using 0.2.3. Thanks, BTW, for odd splits on the FT-60.
I'm on a Mac, running the latest OS X 10.8.2.

Looks like a regression; chirp is no longer writing the file
It does read it on startup, but it's stuck at the version of Jan 18, which is
likely the last time I used 0.2.3.

The directory is writeable, and a debug.log file is created each session
in ~/.chirp . I tried renaming chirp.config in case the file was locked somehow,
sonow  there is no such file, but chirp now starts up with no history, and doesn't
create the file on exit.

Perhaps I had to enable something and have forgotten. If so, please advise.
I see no preference menu other than the two booleans under "Help".

I tried searching the mail archives and bug list, and didn't see anything
relevant. I got lost in the source at a call to  gtk.main_quit(), and I'm too
new to python to make any real progress on my own. Please advise.

... And just as I was getting ready to hit <send> I thought I'd try once
more, and it created a chirp.config!

Once. A dozen tries since, trying all combinations of toggling the help
booleans, loading and closing a .img file, attempting to read or write a
radio, ... and that one success has not been repeated.
So it's not just broken, it's flakey. Sorry.

If there's anything else I can do to support resolving this, let me know.

Thanks and regards,


More information about the chirp_users mailing list