[chirp_users] Getting Started w/ CHIRP on Mac OS X using Kenwood TH-F6 & FTDI cable

Dave Nathanson
Sat Aug 31 13:14:43 PDT 2013

I'm having a problem getting started with CHIRP 0.3.1, I have never used CHIRP before. 
I bought the usb to FTDI cable from Valley Enterprises last week. part# Kenwood USB KPG-22 FTDI as recommended 

I installed the 64 bit version of the FTDI drivers ( FTDIUSBSerialDriver_v2_2_18.dmg ), and when I had problems, I also installed the D2XX drivers. 

I also installed the Python runtime. ( KK7DS_Python_Runtime_R10.pkg ) from
 Rebooted after installing the drivers & libs. 
My computer is running Mac OS X 10.8.4. I'm a long time Mac guy, always open to learning from everybody. Before posting I have searched around & dug through several months of list archives. So hopefully I am giving you guys good info to help me. I apologize for the length of this message. 

To begin, I turn the radio on (Kenwood TH-F6) and plug in the FTDI cable between the radio & the computer. 
When I launch CHIRP, it opens with a blank window. I can pull the menu to "Download from Radio" then it asks me to select the port, make & model of radio. 
Screen pictures:

When I click the OK button, the radio light flashes once, as if the ptt was quickly pressed, the main window flashes once and nothing else happens. Still a blank window. It does not ask me where I would like to save anything. THe radio doesn't seem to be doing anything either. 

When I plug in the cable first, then power on the radio, it goes to the 2 line A/B display with a memory name repeater on the bottom line & blinking PF# on the top line. This also locks the keypad. You can't even power off without unplugging the cable. CHIRP does the same thing, regardless. That is it displays the dialog box for what port, then the CHRIP window dims briefly then comes back as front window in a couple of seconds. 

I downloaded the daily build just in case, but it does the same thing. 

If I disconnect the FTDI cable, before launching CHIRP & trying to download from radio, then CHIRP reports the port does not exist. So that seems to indicate that the drivers are installed since it only gets that error when the cable is disconnected. I have tried plugging the FTDI cable into both the keyboard hub and directly into the computer. No difference. If I open Terminal and type:
dnathanson:~ david$ ls /dev/cu*

if I type kextstat it returns a whole page list of kexts, including this one at the bottom:
  142    0 0xffffff7f81fc8000 0x8000     0x8000     com.FTDI.driver.FTDIUSBSerialDriver (2.2.18) <112 32 5 4 3 1>

I also have the FTDI cable for a Yaesu radio, which I have not tried yet. 

I looked at the log (~/.chirp/debug.log), here is the bottom of it: 

Registered Wouxun_KG816 = KG816Radio
Icon /usr/share/pixmaps/chirp.png not found
Initialized MacOS support
/Applications/chirp-0.3.1.app/Contents/MacOS/../Resources/chirp/chirpw:128: PangoWarning: error opening config file '../Resources/etc/pango/pangorc': No such file or directory

User selected Kenwood TH-F6 on port /dev/cu.usbserial-A501XQ5I
Trying ID at baud 9600
Timeout waiting for data
Trying ID at baud 19200
Timeout waiting for data
Trying ID at baud 38400
Timeout waiting for data
Trying ID at baud 57600
Timeout waiting for data
Traceback (most recent call last):
  File "/Applications/chirp-0.3.1.app/Contents/Resources/chirp/chirpui/mainapp.py", line 1241, in mh
  File "/Applications/chirp-0.3.1.app/Contents/Resources/chirp/chirpui/mainapp.py", line 628, in do_download
    radio = settings.radio_class(ser)
  File "/Applications/chirp-0.3.1.app/Contents/Resources/chirp/chirp/kenwood_live.py", line 123, in __init__
    radio_id = get_id(self.pipe)
  File "/Applications/chirp-0.3.1.app/Contents/Resources/chirp/chirp/kenwood_live.py", line 88, in get_id
    raise errors.RadioError("No response from radio")
chirp.errors.RadioError: No response from radio

Any suggestions? Am I making some obvious newbie mistake? How should we troubleshoot this?

 Dave Nathanson

More information about the chirp_users mailing list