[chirp_users] Problems under Ubuntu 11.10?

Dave Passey
Tue Oct 25 01:35:40 PDT 2011

Hello All,

My first post here, so I hope I'm in the right place!  I'm Dave M0MYA, a 
radio amateur from the UK.  My main interests are operating homebrew and /P.

I'm trying to get Chirp going under Ubuntu 11.10 in order to program my 
Baofeng UV-3R.  I'm a reasonably experienced linux user of a few years 
now, so I'm not afraid to tinker, but I can't seem to get chirp going.  
Here is the saga:

Trying to add the repository results in:

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring 
--secret-keyring /tmp/tmp.FpswDtepWR --trustdb-name /etc/apt/trustdb.gpg 
--keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg 
--keyserver hkp://keyserver.ubuntu.com:80/ --recv 
gpg: requesting key 99B3CC86 from hkp server keyserver.ubuntu.com
gpg: key 99B3CC86: "Launchpad PPA for Steve Conklin" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1

So I tried the tarball.  All extracted and tried running from a 
console.  It fires up, but only gives me a blank window.  It can be 
closed from the window bar, with nothing spat out on the console.  
Ending it by entering Ctl-C at the console results in the following output:

dave at major-tom:~/Desktop/chirp-0.1.12$ ./chirpw
CHIRP 0.1.12 on Linux - Ubuntu 11.10
^CTraceback (most recent call last):
   File "./chirpw", line 69, in <module>

The only clue I have is that the package python-gtk does not appear to 
be installed, nor does Ubuntu know much about it (the other python 
modules listed on the Chirp wiki are present and correct):

dave at major-tom:~/Desktop/chirp-0.1.12$ sudo apt-get install python-gtk
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package python-gtk is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'python-gtk' has no installation candidate

So - my guess here is the the shiny new Ubuntu does not make python-gtk 
available in the repositories.  Something to do with Gnome 3 perhaps?  I 
don't know - this is where I draw a blank!  Any assistance much appreciated.

Dave M0MYA.

More information about the chirp_users mailing list