[chirp_users] FT-60R / Chirp 0.1.12 / Ubuntu 11.04 Read _mem.tmode error

Leigh L. Klotz, Jr WA5ZNU Leigh at WA5ZNU.org
Sun Nov 6 13:57:42 PST 2011


On 11/06/2011 01:50 PM, Dan Smith wrote:
>> I was wrong about the reading: it fails in read.
>>
>> The value _mem.tone is 0x74 and gets IndexError as I determined with
>> this change:
>>
>>            try:
>>                mem.tmode = TMODES[_mem.tmode]
>>            except:
>>                print "TMODES failed tmode is %s" % (_mem.tmode)
> This is not an error during the read, it's an error while parsing the
> image. You should still be able to save the .img file, so please file a
> bug and attach the image so I can take a look and try to figure out
> what's going on.

I'll upload the img file later today.

I've put in a few try/except indexerror and have printed out the 
offending values below.
Mem 3 doesn't have text programmed for label and if I set it to ALPHA it 
shows as MEM003 on the radio.
I dunno what mem0 is; perhaps it's the calling freq?

This is a brand new radio that I programmed a few memories in by hand, 
so perhaps this is symptomatic of some uninitialized areas.

Starting memedit
TMODES failed tmode is 0x07 (.....111b) in mem 0
TONES failed tone is 0x3F (..111111b) in mem 0
DTCS_CODES failed DTCS is 0x7F (.1111111b) in mem 0
POWER_LEVELS failed POWER_LEVEL is 0x03 (......11b) in mem 0
charset out of range 0x74 in mem number 3
Bank Index supported: False
Bank supported: False
DTCS Code supported: True
DTCS Pol supported: False
Mode supported: True
Offset supported: True
Name supported: True
Tune Step supported: True
Name supported: True
ToneSql supported: False
Cross Mode supported: False
TMODES failed tmode is 0x07 (.....111b) in mem 0
TONES failed tone is 0x3F (..111111b) in mem 0
DTCS_CODES failed DTCS is 0x7F (.1111111b) in mem 0
POWER_LEVELS failed POWER_LEVEL is 0x03 (......11b) in mem 0
charset out of range 0x74 in mem number 3

Leigh/WA5ZNU




More information about the chirp_users mailing list