[chirp_users] Thoughts on TH-F6A support and looking for D710 support

David Ranch chirp at trinnet.net
Sat Feb 5 16:13:06 PST 2011


> Ah, I see the problem.  That second-to-last line should be "MNA 0,055".
>  It has an extra "MNA" in there and the radio NAKs it with 'N'.  I
> should be able to fix that here and shoot you an update to verify.
>   
Ok, let me know when you find some time to change that and I'll test it.

>> 1) I cannot save the download memories.  The File --> Save and "Save As" 
>> are greyed out.  Maybe these options aren't used as there is Radio --> 
>> "Export to" ?
>>     
>
> Correct.  "Save" means "Save an image".  There is no image for a live
> radio, so you can't do that.
>
> I've already added the aforementioned notice dialog, which explains
> this.  You should see that in the next round.
>   
I just tried out the chirp-hg-6e6ab5a16f39 TIP and that dialog box is 
perfect!  That helps a lot!



>> 2) By default, when downloading the memories on a THF6A, it downloads 
>> memories 0-399 but displays 0-25.  If I change the "Memories Memory 
>> range" to say
>> 0-399 and click on go, it re-downloads  all 400 memories which takes a 
>> long time.  This re-download should be suppressed.
>>     
>
> It's cached on some of the other live radios, and I can do the same for
> the kenwood ones.  You are, I believe, the first person to attempt using
> the kenwood driver(s) other than myself and a small circle of friends :)
>   
If you download all 400 memories, why limit the display to only the 
first 25?  Why not make the default display
be 0-399?

Anyway, I'll keep the comments coming and I intend them only to be 
constructive.. by no means am I nitpicking at this fantastic and 
appreciated tool!


>> 3) If I try to edit an entry, say memory slot 55, and I type in a 
>> repeater name and then hit enter, I get a dialog box saying "Error 
>> setting memory: Frequency
>> 0.000000 is out of range."  It then proceeds to re-read the entire 
>> radio's memory which take a while (this re-download should be 
>> suppressed.  The UI should either require the user to enter in the 
>> frequency FIRST or it should let the user enter in the memory's name but 
>> not upload the name it until a frequency is also entered in.
>>     
>
> That has been fixed in the repository already, since the beta you are
> using was posted.
>   
This newest tip of tree still shows the same behavior but there is a new 
bug.  It seems to be sendingsomething  which freaks out the radio out 
and again, the name is shifting from D7 to E7:
--
was
D7->PC: N
PC->D7: MR 0,053
D7->PC: MR 0,053,00224040000,7,2,0,1,0,0,12,08,000,001600000,0,0
PC->D7: MNA 0,053

now
PC->D7: MR 0,059
D7->PC: N
PC->D7: MR 0,060
D7->PC: N
PC->D7: MW 0,054,00224000000,0,0,0,0,0,0,08,08,000,000600000,0,0
E7->PC: E
PC->D7: MNA 054,
E7->PC: E
PC->D7: MW 0,054,00224000000,0,0,0,0,0,0,08,08,000,000600000,0,0
E7->PC: E
PC->D7: MNA 054,
E7->PC: E
PC->D7: MW 0,054,00224000000,0,0,0,0,0,0,08,08,000,000600000,0,0
E7->PC: E
PC->D7: MNA 054,test
E7->PC: E
PC->D7: MR 0,000
E7->PC: E
E't sure what to do with this: `E
Exception running RadioJob: Unexpected result returned from radio
-- Exception: --
Traceback (most recent call last):
  File "/usr/src/archive/Chirp/chirp-hg-6e6ab5a16f39/chirpui/common.py", 
line
70, in execute
    result = func(*self.args, **self.kwargs)
  File "/usr/src/archive/Chirp/chirp-hg-6e6ab5a16f39/chirp/kenwood_live.py",
line 129, in get_memory
    raise errors.RadioError("Unexpected result returned from radio")
RadioError: Unexpected result returned from radio
------
Job Args:   (0,)
Job KWArgs: {}
PC->D7: MR 0,019
E7->PC: E
E't sure what to do with this: `E
Exception running RadioJob: Unexpected result returned from radio
-- Exception: --
Traceback (most recent call last):
  File "/usr/src/archive/Chirp/chirp-hg-6e6ab5a16f39/chirpui/common.py", 
line
70, in execute
    result = func(*self.args, **self.kwargs)
  File "/usr/src/archive/Chirp/chirp-hg-6e6ab5a16f39/chirp/kenwood_live.py",
line 129, in get_memory
    raise errors.RadioError("Unexpected result returned from radio")
RadioError: Unexpected result returned from radio
------

I'm also seeing a behavior that I don't know is the radio, the USB 
cable, or something Chirp is doing but the serial system is getting 
corrupt and I have to disconnect the radio from the USB cable, the 
computer from the cable, let it deplete all it's energy and then things
work again:
--
info on the cable itself from Dmesg:

usb 3-1: new full speed USB device using uhci_hcd and address 14
usb 3-1: configuration #1 chosen from 1 choice
pl2303 3-1:1.0: pl2303 converter detected
usb 3-1: pl2303 converter now attached to ttyUSB0


When I start either Chirp 0.1.11b4 or the TIP of tree version:

PC->V71: ID
V71->PC:
PC->V71: ID
V71->PC:
f?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?ff?
PC->V71: ID
V71->PC:
x?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx???xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?xx?x
PC->V71: ID
V71->PC:
???????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????
--- Exception Dialog: Unable to probe radio model ---
Traceback (most recent call last):
  File "/usr/src/archive/Chirp/chirp-hg-6e6ab5a16f39/chirpui/clone.py", line
150, in run
    cs.radio_class = detect.DETECT_FUNCTIONS[vendor](cs.port)
  File "/usr/src/archive/Chirp/chirp-hg-6e6ab5a16f39/chirp/detect.py", line
101, in detect_kenwoodlive_radio
    raise errors.RadioError("Unable to probe radio model")
RadioError: Unable to probe radio model
----------------------------
--

--David
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://intrepid.danplanet.com/pipermail/chirp_users/attachments/20110205/1fd50b21/attachment-0002.html 


More information about the chirp_users mailing list