[chirp_users] more help with Mac OS

Debbie Fligor n9dn at arrl.net
Mon May 18 10:23:34 PDT 2009


Okay, sometimes I'm just dense.

I made two code changes, which took care of my problem (I probably  
only needed one, but hey...)

in platform.py on line 219:

  return sorted(glob.glob("/dev/ttyS*") + glob.glob("/dev/ttyUSB*") +  
glob.glob("/dev/cu.usbser*") + glob.glob("/dev/tty.Key*"))


I added the /dev/tty.Key* option to go with the other ones  had I  
looked this up, a symlink to /dev/ttyUSB* (without the "." between tty  
and USB) would have probably worked too.

and in ic9x.py on line 306 I replaced the default serial port you had  
listed with mine:

         r = IC9xRadioB(serial.Serial(port="/dev/tty.KeySerial1",


I think perhaps that the first one is what the overall code needs, but  
the second one is what showed up in my serial port choice window  
(which I got to with no error) and since I found it first and it  
worked I left it.


On May 17, 2009, at 21:34, Debbie Fligor wrote:

> Hi Dan,
> On May 15, 2009, at 5:40, Dan Smith wrote:
>>
>> This looks to me like the same issue we've had in the past with MacOS
>> where it doesn't find any ports and croaks on that fact.  I fixed it
>> in D-RATS but might have forgotten to fix it in CHIRP as well.  If  
>> you
>> fool it into thinking there is a serial device, it might be happy.
>>
>> Something like: "touch /dev/tty.usbserial9" or something will give it
>> something to populate that list with.
>
> well touch doesn't like /dev, but you can use ln -s  but adding  
> tty.usbserial9 as a link to tty.KeySerial1  doesn't seem to help any  
> at all.
>>
>> Sorry, not much of an answer, but if this doesn't help, I'll try to
>> explain more and/or fix it later on :)
>
> sounds good to me!
>
> thanks!




More information about the chirp_users mailing list