[chirp_users] more help with Mac OS

Dan Smith dsmith at danplanet.com
Fri May 15 03:40:35 PDT 2009


Hi Debbie,

> I'm sure that you're busy with d-rats and getting ready for Dayton,
> but I finally got back to working on getting Chirp working now that
> I have a need to move data from an ic-92 to an ic-91 :-)

Yeah, I'm slammed at the moment with a variety of things.

> I snagged the source to 0.1.9 final and tried it both with my fink  
> install and my darwin ports install.  neither works, but they do both  
> fail with the exact same error when I pick "Radio -> connect to an  
> ic9x":
>
>   a.show()
> Traceback (most recent call last):
>   File "/Users/fligor/bin/chirp-0.1.9/chirpui/mainapp.py", line 430,  
> in mh
>     self.do_open9x(ic9x.IC9xRadioA)
>   File "/Users/fligor/bin/chirp-0.1.9/chirpui/mainapp.py", line 123,  
> in do_open9x
>     rtype="ic9x")
>   File "/Users/fligor/bin/chirp-0.1.9/chirpui/clone.py", line 70, in  
> __init__
>     self.port = miscwidgets.make_choice(ports, True, ports[0])
> IndexError: list index out of range
>
> I never get the dialog box that lets you choose your radio settings.
>
> I tried A B and B B, neither worked, and I did make sure the radio's  
> main was on the "B" side.
>
> I even get the same message with the Apple's built in python using
>
> export PYTHONPATH=/opt/local/lib/python2.5/site-packages
>
> which worked for another user.  It's good that they all fail the same  
> way, it's annoying that they all fail :-)
>
>
> You'd previously thought you knew what this was and had planned on  
> fixing it, I just got side tracked and never checked.  Something about  
> not knowing about a serial port and getting confused.  as a work  
> around, is there a config file I can stash somewhere that fills it in  
> about the serial port to get me going?
>
> I couldn't find anything on the config file format at the wiki so that  
> I could just make my own.  Let me know if  you also want to see this  
> on trac as well.

This looks to me like the same issue we've had in the past with MacOS
where it doesn't find any ports and croaks on that fact.  I fixed it
in D-RATS but might have forgotten to fix it in CHIRP as well.  If you
fool it into thinking there is a serial device, it might be happy.

Something like: "touch /dev/tty.usbserial9" or something will give it
something to populate that list with.

Sorry, not much of an answer, but if this doesn't help, I'll try to
explain more and/or fix it later on :)

-- 
Dan Smith
dsmith#danplanet.com, s/#/@/
www.danplanet.com
KK7DS



More information about the chirp_users mailing list